summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristian Hergert <chergert@redhat.com>2020-07-27 12:49:57 -0700
committerChristian Hergert <chergert@redhat.com>2020-07-27 12:49:57 -0700
commit0243736003cbe3396d6469cd66d186c5e0a53169 (patch)
treef4210874ca5c8cbd0a5b1eb0aed94ea6610842ad /meson.build
parentc6c9ca60096a75dfc0e218408289b169b1f34551 (diff)
downloadgtk+-0243736003cbe3396d6469cd66d186c5e0a53169.tar.gz
macos: support ARM/PowerPC time conversion for DisplayLink times
When converting DisplayLink frame presentation times, we need to take into account the arch-specific types. This tracks changes in GNOME/GLib!1566 so that precision is not lost.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 43208bc669..3ab900eb06 100644
--- a/meson.build
+++ b/meson.build
@@ -207,6 +207,17 @@ foreach func : check_functions
endif
endforeach
+# Check for __uint128_t (gcc) by checking for 128-bit division
+uint128_t_src = '''int main() {
+static __uint128_t v1 = 100;
+static __uint128_t v2 = 10;
+static __uint128_t u;
+u = v1 / v2;
+}'''
+if cc.compiles(uint128_t_src, name : '__uint128_t available')
+ cdata.set('HAVE_UINT128_T', 1)
+endif
+
# Disable deprecation checks for all libraries we depend on on stable branches.
# This is so newer versions of those libraries don't cause more warnings with
# a stable GTK version.