summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2021-01-29 18:46:32 -0500
committerXavier Claessens <xavier.claessens@collabora.com>2021-03-08 21:19:09 -0500
commit629e70f89dd1c8c4a1b80f0ea67e6e7e4698485c (patch)
tree6a9caa8e75e698d7973ef0f26df128625be12b69 /meson.build
parentcba8c40aa0818b8501c46c4ff2d5c8785d32a3c1 (diff)
downloadgtk+-629e70f89dd1c8c4a1b80f0ea67e6e7e4698485c.tar.gz
Meson: Use gnome.post_install()
See https://github.com/mesonbuild/meson/pull/8272 and https://github.com/mesonbuild/meson/issues/8268.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build21
1 files changed, 14 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 145a848a86..a60e061b96 100644
--- a/meson.build
+++ b/meson.build
@@ -798,14 +798,21 @@ subdir('po-properties')
subdir('docs/tools')
subdir('docs/reference')
-# Keep this in sync with post-install.sh expected arguments
if not meson.is_cross_build()
- meson.add_install_script('build-aux/meson/post-install.py',
- gtk_api_version,
- gtk_binary_version,
- gtk_libdir,
- gtk_datadir,
- gtk_bindir)
+ if meson.version().version_compare('>=0.57.0')
+ gnome.post_install(
+ glib_compile_schemas: true,
+ gio_querymodules: gio_module_dirs,
+ gtk_update_icon_cache: true,
+ )
+ else
+ meson.add_install_script('build-aux/meson/post-install.py',
+ gtk_api_version,
+ gtk_binary_version,
+ gtk_libdir,
+ gtk_datadir,
+ gtk_bindir)
+ endif
else
message('Not executing post-install steps automatically when cross compiling')
endif