summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2020-05-30 14:45:47 +0000
committerMatthias Clasen <mclasen@redhat.com>2020-05-30 14:45:47 +0000
commitfd73f8d972550d6dc13abbeb03b81eff906c056f (patch)
tree3e7ce639cb19dd6d1277e3a4bed15c883dca5505 /meson.build
parent3a8ebf4c9f7d5202eeb7937371318d5e682151a8 (diff)
parentb482b7d8af073fd43e3e0a1ba5cf40fce33c6c34 (diff)
downloadgtk+-fd73f8d972550d6dc13abbeb03b81eff906c056f.tar.gz
Merge branch 'pango-bump-v2' into 'master'
pango version bump v2 See merge request GNOME/gtk!1987
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 486ea08672..fc0b1ef7fc 100644
--- a/meson.build
+++ b/meson.build
@@ -27,7 +27,7 @@ else
endif
glib_req = '>= @0@.@1@.@2@'.format(glib_major_req, glib_minor_req, glib_micro_req)
-pango_req = '>= 1.44.4'
+pango_req = '>= 1.45.0'
fribidi_req = '>= 0.19.7'
atk_req = '>= 2.15.1'
cairo_req = '>= 1.14.0'
@@ -352,10 +352,11 @@ fribidi_dep = dependency('fribidi', version: fribidi_req,
# Require PangoFT2 if on X11 or wayland
require_pangoft2 = wayland_enabled or x11_enabled
-pangoft_dep = dependency('pangoft2', required: false)
if require_pangoft2
pangoft_dep = dependency('pangoft2', fallback : ['pango', 'libpangoft2_dep'])
+else
+ pangoft_dep = dependency('pangoft2', required: false)
endif
if win32_enabled