summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2021-10-05 04:14:57 +0200
committerBenjamin Otte <otte@redhat.com>2021-10-06 03:43:47 +0200
commitae8de7168ad9ff86b51939d873ff475d77091f30 (patch)
treea80fe9aa7cac26d72568b4d9eae1cd9286fa7f76 /meson.build
parent04da2ff7c881b4200d52467ad071d4247fb096c2 (diff)
downloadgtk+-ae8de7168ad9ff86b51939d873ff475d77091f30.tar.gz
build: Add a HAVE_EGL define to config.h
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 8 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index bea2015429..897de13766 100644
--- a/meson.build
+++ b/meson.build
@@ -481,7 +481,15 @@ if not cairo_csi_dep.found()
cairo_csi_dep = cc.find_library('cairo-script-interpreter', required: get_option('build-tests'))
endif
+have_egl = epoxy_dep.get_variable(
+ pkgconfig: 'epoxy_has_egl',
+ internal: 'epoxy_has_egl',
+ default_value: '0') == '1'
+
cdata.set('HAVE_CAIRO_SCRIPT_INTERPRETER', cairo_csi_dep.found())
+if have_egl
+ cdata.set('HAVE_EGL', 1)
+endif
cdata.set('HAVE_HARFBUZZ', harfbuzz_dep.found())
cdata.set('HAVE_PANGOFT', pangoft_dep.found())
@@ -589,10 +597,6 @@ if win32_enabled
pc_gdk_extra_libs += ['-lwinmm', '-ldwmapi', '-lsetupapi', '-lcfgmgr32']
# Check whether libepoxy is built with EGL support on Windows
- win32_has_egl = epoxy_dep.get_variable(
- pkgconfig: 'epoxy_has_egl',
- internal: 'epoxy_has_egl',
- default_value: '0') == '1'
endif
# Check for bind_textdomain_codeset, including -lintl if GLib brings it in by