summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlexander Kanavin <alex@linutronix.de>2023-01-02 15:00:02 +0100
committerAlexander Kanavin <alex@linutronix.de>2023-01-03 08:26:07 +0100
commitae71d338d79abe5af5ec2437f41c80da0395affc (patch)
treea746195ce5b7e120f7a32056a8c1e321f283eb26 /meson.build
parent8b469a2727741a9864eca3e1d56e491ea5db65c2 (diff)
downloadgtk+-ae71d338d79abe5af5ec2437f41c80da0395affc.tar.gz
meson.build: build introspection according to option only
The way the check is written, if the build is native, then the introspection option has no effect. Particularly yocto project does want to disable introspection in native builds and enable it in cross builds (both via the option), and without this patch the former is not possible. Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ab46c7dcda..4282f2701c 100644
--- a/meson.build
+++ b/meson.build
@@ -730,7 +730,7 @@ endif
# Introspection
gir = find_program('g-ir-scanner', required : get_option('introspection'))
-build_gir = gir.found() and (not meson.is_cross_build() or get_option('introspection').enabled())
+build_gir = gir.found() and get_option('introspection').enabled()
project_build_root = meson.current_build_dir()