summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMichal Vasilek <michal@vasilek.cz>2022-09-18 20:48:21 +0200
committerMichal Vasilek <michal@vasilek.cz>2022-09-20 01:27:26 +0200
commit98796d4513f04cb2f4dbe55fa55af4504b1ac610 (patch)
treead30cd604088e990dcb4f4eea756fdfcec2f9334 /meson.build
parent2bbf7d267ad063d683db8a2b533255657c848409 (diff)
downloadgtk+-98796d4513f04cb2f4dbe55fa55af4504b1ac610.tar.gz
build: fix gi-docgen detection in cross builds
gi-docgen is supposed to be ran natively on the build machine, without native: true dependency() searches for gi-docgen on the host system. When it doesn't find it, it falls back to a subproject even if gi-docgen is available on the build machine. also make gtk_doc require introspection
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f45da9dce3..a4e69be6d1 100644
--- a/meson.build
+++ b/meson.build
@@ -443,7 +443,8 @@ iso_codes_dep = dependency('iso-codes', required: false)
gidocgen_dep = dependency('gi-docgen', version: '>= 2021.1',
fallback: ['gi-docgen', 'dummy_dep'],
- required: get_option('gtk_doc'))
+ required: get_option('gtk_doc') and get_option('introspection').enabled(),
+ native: true)
gi_dep = dependency('gobject-introspection-1.0', version: introspection_req,
required: get_option('introspection').enabled() and
get_option('build-tests'))