summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@archlinux.org>2022-03-10 00:08:36 -0500
committerEli Schwartz <eschwartz@archlinux.org>2022-03-10 00:08:36 -0500
commit94007caf8d0d5439e3575a337fdb94ecdc2f06ad (patch)
tree1b445acb87786d0cbc568cbcc2e8d2c71f346185 /meson.build
parent675c8b45b1dcd1fc67cfd14147ba52b1c5a6cbe8 (diff)
downloadgtk+-94007caf8d0d5439e3575a337fdb94ecdc2f06ad.tar.gz
meson: use proper handling of wayland-protocols dependency
Ensure that resolution of the subproject occurs via the dependency interface, not the "poke at subprojects manually" interface, and make that actually work via --wrap-mode=forcefallback. There's no need to mark it as not-required and then manually invoke subproject(), since fallback should work correctly and it is always needed. However, if fallback was performed (or forced) it would error out since get_variable() was instructed to only use pkg-config while the relevant variable was exported by the subproject as an internal fallback dependency.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index e940de27ca..8076d3eb41 100644
--- a/meson.build
+++ b/meson.build
@@ -517,15 +517,11 @@ if wayland_enabled
wlclientdep = dependency('wayland-client', version: wayland_req,
fallback: 'wayland',
default_options: ['documentation=false'])
- wlprotocolsdep = dependency('wayland-protocols', version: wayland_proto_req, required: false)
+ wlprotocolsdep = dependency('wayland-protocols', version: wayland_proto_req)
wlegldep = dependency('wayland-egl',
fallback: 'wayland')
- if not wlprotocolsdep.found()
- wlproto_dir = subproject('wayland-protocols').get_variable('wayland_protocols_srcdir')
- else
- wlproto_dir = wlprotocolsdep.get_variable(pkgconfig: 'pkgdatadir')
- endif
+ wlproto_dir = wlprotocolsdep.get_variable('pkgdatadir')
wayland_pkgs = [
'wayland-client @0@'.format(wayland_req),