summaryrefslogtreecommitdiff
path: root/gtk/meson.build
diff options
context:
space:
mode:
authorChristian Hergert <chergert@redhat.com>2018-05-04 17:46:08 -0700
committerChristian Hergert <chergert@redhat.com>2018-05-04 17:46:08 -0700
commit613f7609c203fad1f91f136f59f7c9f623defb2f (patch)
treef88a8b12f855f42dd10d45d88bd8853e731fba0d /gtk/meson.build
parent0f0be1ee8e65bfab7c9060b99c5a5118503e6084 (diff)
downloadgtk+-613f7609c203fad1f91f136f59f7c9f623defb2f.tar.gz
build: fix meson.build when quartz is used
We need access to the variable earlier in the file when the quartz backend is being setup.
Diffstat (limited to 'gtk/meson.build')
-rw-r--r--gtk/meson.build18
1 files changed, 9 insertions, 9 deletions
diff --git a/gtk/meson.build b/gtk/meson.build
index 0502ab91fd..6d4084a672 100644
--- a/gtk/meson.build
+++ b/gtk/meson.build
@@ -2,6 +2,15 @@ subdir('deprecated')
subdir('a11y')
subdir('inspector')
+gtk_cargs = [
+ '-DGTK_COMPILATION',
+ '-DG_LOG_DOMAIN="Gtk"',
+ '-DGTK_PRINT_BACKEND_ENABLE_UNSUPPORTED',
+ '-DGTK_BINARY_VERSION="@0@"'.format(gtk_binary_version),
+ '-DGTK_HOST="@0@"'.format(host_machine.system()),
+ '-DGTK_DATA_PREFIX="@0@"'.format(gtk_prefix),
+]
+
# List of sources that do not contain public API, and should not be
# introspected
gtk_private_sources = files([
@@ -827,15 +836,6 @@ gtkversion = configure_file(input: 'gtkversion.h.in',
configuration: gtkversion_cdata,
install_dir: join_paths(gtk_includedir, 'gtk-4.0/gtk'))
-gtk_cargs = [
- '-DGTK_COMPILATION',
- '-DG_LOG_DOMAIN="Gtk"',
- '-DGTK_PRINT_BACKEND_ENABLE_UNSUPPORTED',
- '-DGTK_BINARY_VERSION="@0@"'.format(gtk_binary_version),
- '-DGTK_HOST="@0@"'.format(host_machine.system()),
- '-DGTK_DATA_PREFIX="@0@"'.format(gtk_prefix),
-]
-
gtk_gen_headers = [
gtkmarshal_h,
gtktypebuiltins_h,