summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorMatt Wilson <msw@redhat.com>2001-09-18 13:26:52 +0000
committerMatt Wilson <msw@src.gnome.org>2001-09-18 13:26:52 +0000
commitcbae279486cd8d098be6ad9023fac6ed10fab20e (patch)
treed3f5b0ffbbd5c3da527e01a9a75506a913121ea9 /gtk/Makefile.am
parenta25167914836070833b1720933d048ba82a40c64 (diff)
downloadgtk+-cbae279486cd8d098be6ad9023fac6ed10fab20e.tar.gz
don't use += before =
2001-09-18 Matt Wilson <msw@redhat.com> * docs/Makefile.am (EXTRA_DIST): don't use += before = * docs/faq/Makefile.am (EXTRA_DIST): likewise * docs/tutorial/Makefile.am (EXTRA_DIST): likewise * gdk/Makefile.am (MAINTAINERCLEANFILES): likewise (EXTRA_HEADERS): likewise * gtk/Makefile.am (MAINTAINERCLEANFILES): likewise (EXTRA_HEADERS): likewise (EXTRA_DIST): likewise (CLEANFILES): likewise * gtk/stock-icons/Makefile.am (CLEANFILES): likewise * tests/Makefile.am (EXTRA_DIST): likewise * Makefile.am (install-data-local): changed to use install-data-hook, which runs after install-pkgconfigDATA, so that the pkgconfigdir will have been created and populated first. gdk-pixbuf/ChangeLog 2001-09-17 Matt Wilson <msw@redhat.com> * Makefile.am (libpixbufloader_xbm_la_LDFLAGS): removed duplicate LDFLAGS definition, use the -avoid-version one. (libpixbufloader_tga_la_LDFLAGS): likewise
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 77c92c453b..831acc91fc 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -401,9 +401,9 @@ gtk_extra_sources = @STRIP_BEGIN@ \
#
gtk_target_headers = $(gtk_public_h_sources) $(gtk_built_public_sources) gtkversion.h
gtk_target_sources = $(gtk_c_sources) $(gtk_plug_c_sources)
-MAINTAINERCLEANFILES += $(gtk_built_sources)
-EXTRA_HEADERS +=
-EXTRA_DIST += $(gtk_private_h_sources) $(gtk_extra_sources)
+MAINTAINERCLEANFILES = $(gtk_built_sources)
+EXTRA_HEADERS =
+EXTRA_DIST = $(gtk_private_h_sources) $(gtk_extra_sources)
EXTRA_DIST += $(gtk_built_sources)
#
@@ -411,7 +411,7 @@ EXTRA_DIST += $(gtk_built_sources)
#
# setup autogeneration dependancies
gen_sources = xgen-gdef xgen-gtbh xgen-gtbvc xgen-gtbic xgen-gtbec xgen-gmh xgen-gmc
-CLEANFILES += $(gen_sources)
+CLEANFILES = $(gen_sources)
Makefile: oldest-source-stamp # oh boy, does automake SUCK!
oldest-source-stamp: $(gtk_built_sources)
$(OBJECTS): oldest-source-stamp ${gtk_built_public_sources} # this is our oldest file, used for implicit auto-generation deps