summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>2001-03-18 04:50:34 +0000
committerTim Janik <timj@src.gnome.org>2001-03-18 04:50:34 +0000
commitac68581f9655392ab4b41ac5d6b0b76c0adf532f (patch)
tree3a8c1043c94817b941e70dfce7fefb309b0cf517 /gtk/Makefile.am
parent882bb853891b30c98c58d384d311fa24fbd1b326 (diff)
downloadgtk+-ac68581f9655392ab4b41ac5d6b0b76c0adf532f.tar.gz
added rc-style argument GtkSpinButton::shadow_type. removed
Sun Mar 18 01:15:30 2001 Tim Janik <timj@gtk.org> * gtk/gtkspinbutton.[hc]: added rc-style argument GtkSpinButton::shadow_type. removed spin_button->shadow_type, gtk_spin_button_set_shadow_type() and ARG_SHADOW_TYPE as it doesn' make much sense to try to override rc-style settings. * gtk/gtkfixed.c: removed gtk_fixed_paint() (was unused). * gtk/gtkwidget.c: quark cleanups. * gtk/gtkrc.[hc]: added gtk_rc_scanner_new() to create an rc-file scanner with appropriate configuration, renamed GtkRcStyleClass.clone to create_rc_style() (we don't do cloning in standard OO sense). added per rc style properties. * gtk/gtkstyle.[hc]: added code to retrive pspec conformant rc-style property values and for caching those. some cleanups. * gtk/Makefile.am: -DG_DISABLE_CONST_RETURNS. * gtk/gtksettings.[hc]: new file for global rc-file properties (at least currently, should get extended to support X properties and other communication mechanisms). * gtk/gtkwidget.[hc]: added style property support: (gtk_widget_class_install_style_property_parser): install style property pspec with parser function for rc-file values other than LONG, DOUBLE or STRING. (gtk_widget_class_install_style_property): same as above without parser (parsers are going to be needed quite infrequently). (gtk_widget_style_get_property): retrive style property value. (gtk_widget_style_get_valist): same as above with varargs support, has NOCOPY semantics. (gtk_widget_style_get): wrapper around gtk_widget_style_get_valist().
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 623759da91..a33192e884 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -11,6 +11,7 @@ INCLUDES = @STRIP_BEGIN@ \
-DGTK_LOCALEDIR=\"$(gtklocaledir)\" \
-DGTK_VERSION=\"@GTK_VERSION@\" \
-DTESTGTK_RCFILE=\"`pwd`/$(srcdir)/testgtkrc\" \
+ -DG_DISABLE_CONST_RETURNS \
-I$(top_builddir)/gtk \
-I$(top_srcdir) -I../gdk \
-I$(top_srcdir)/gdk \
@@ -147,6 +148,7 @@ gtk_public_h_sources = @STRIP_BEGIN@ \
gtkscrolledwindow.h \
gtkselection.h \
gtkseparator.h \
+ gtksettings.h \
gtksignal.h \
gtksocket.h \
gtkspinbutton.h \
@@ -306,6 +308,7 @@ gtk_c_sources = @STRIP_BEGIN@ \
gtkscrolledwindow.c \
gtkselection.c \
gtkseparator.c \
+ gtksettings.c \
gtksignal.c \
gtksocket.c \
gtkspinbutton.c \