summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorChristopher Blizzard <blizzard@redhat.com>2000-06-09 02:05:17 +0000
committerChristopher Blizzard <blizzard@src.gnome.org>2000-06-09 02:05:17 +0000
commit40298ef908827fdde7f30a7ee18dd1d6d65c3ae4 (patch)
tree75c9b56b467e7a500eed91d7f2d1fb21b30d7ce3 /gtk/Makefile.am
parentba0567786bdd5736f8755b8877a3748fe75d0cc5 (diff)
downloadgtk+-40298ef908827fdde7f30a7ee18dd1d6d65c3ae4.tar.gz
deps include libgtk-x11.la, not libgtk.la (LDADDS): include libgtk-x11.la
Thu Jun 8 21:54:51 2000 Christopher Blizzard <blizzard@redhat.com> * gtk/Makefile.am (DEPS): deps include libgtk-x11.la, not libgtk.la (LDADDS): include libgtk-x11.la and libgdk-x11.la, not the non-x11 versions * gtk/gtklabel.c (gtk_label_get_text): Make sure that the error checking macros return NULL since the function has a return value.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index cb59e29e4f..d5fb16300a 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -512,10 +512,10 @@ uninstall-local:
# test programs, not to be installed
#
noinst_PROGRAMS = testgtk testcalendar testinput testselection testrgb testdnd testtext simple testtextbuffer # testthreads
-DEPS = libgtk.la $(top_builddir)/gdk/libgdk.la
+DEPS = libgtk-x11.la $(top_builddir)/gdk/libgdk-x11.la
LDADDS = @STRIP_BEGIN@ \
- libgtk.la \
- $(top_builddir)/gdk/libgdk.la \
+ libgtk-x11.la \
+ $(top_builddir)/gdk/libgdk-x11.la \
@x_ldflags@ \
@x_libs@ \
@GDK_WLIBS@ \