summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorAnders Carlsson <andersca@imendio.com>2006-03-27 11:34:43 +0000
committerAnders Carlsson <andersca@src.gnome.org>2006-03-27 11:34:43 +0000
commitf09810e02542ab35c506109c83db4ac72804a0cc (patch)
tree820a4604cd7f0ab87457a39f508932b91247dbc3 /gtk/Makefile.am
parentce823f5b284404aecb2b8fe388dd0e3df10fe84d (diff)
downloadgtk+-f09810e02542ab35c506109c83db4ac72804a0cc.tar.gz
Add -xobjective-c to cflags. (#335956, Lllian Angel)
2006-03-27 Anders Carlsson <andersca@imendio.com> * gtk/Makefile.am: Add -xobjective-c to cflags. (#335956, Lllian Angel) * gtk/gtkdnd-quartz.c: (gtk_drag_dest_set_track_motion): (gtk_drag_dest_get_track_motion): Add stubs for new functions. (#335955, Lillian Angel)
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 9f4a942ba9..4d24311b87 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -27,7 +27,8 @@ INCLUDES = \
-DGTK_DISABLE_DEPRECATED \
-DGTK_FILE_SYSTEM_ENABLE_UNSUPPORTED \
$(GTK_DEBUG_FLAGS) \
- $(GTK_DEP_CFLAGS)
+ $(GTK_DEP_CFLAGS) \
+ $(gtk_clipboard_dnd_c_sources_CFLAGS)
gtarget=$(gdktarget)
@@ -566,6 +567,7 @@ gtk_clipboard_dnd_c_sources = gtkclipboard-quartz.c gtkdnd-quartz.c gtkquartz.c
gtk_clipboard_dnd_c_sources_CFLAGS = "-xobjective-c"
else
gtk_clipboard_dnd_c_sources = gtkclipboard.c gtkdnd.c
+gtk_clipboard_dnd_c_sources_CFLAGS =
endif
# we use our own built_sources variable rules to avoid automake's