summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2007-03-15 19:33:57 +0000
committerEmmanuele Bassi <ebassi@src.gnome.org>2007-03-15 19:33:57 +0000
commitccf49466a64602051ddffca43488b77576abeab2 (patch)
tree2695b60d9ff5e30516ee4950860bd3ac0a778254 /gtk/Makefile.am
parent0b1c9b7cc26d293477a6823a40d3e1feebbd6df7 (diff)
downloadgtk+-ccf49466a64602051ddffca43488b77576abeab2.tar.gz
Add GtkActionClass::get_submenu() vfunc: actions providing a menu item or
2007-03-15 Emmanuele Bassi <ebassi@gnome.org> * gtk/gtkaction.[ch]: Add GtkActionClass::get_submenu() vfunc: actions providing a menu item or a menu tool button with already a submenu should return the GtkMenu widget. * gtk/gtkuimanager.c (update_node): If an action provides its own submenu, use it instead of adding an empty one * gtk/gtkrecentaction.[ch]: Add GtkRecentAction, an action implementing the GtkRecentChooser interface for displaying the list of recently used files into menus and toolbars generated using GtkUIManager. (#338843) * gtk/Makefile.am: * gtk/gtk.h: * gtk/gtk.symbols: Add GtkRecentAction API to the build. * tests/testactions.c: Exercise the GtkRecentAction API. svn path=/trunk/; revision=17524
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 82c4afd712..ce5d48f369 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -250,6 +250,7 @@ gtk_public_h_sources = \
gtkradiotoolbutton.h \
gtkrange.h \
gtkrc.h \
+ gtkrecentaction.h \
gtkrecentchooser.h \
gtkrecentchooserdialog.h \
gtkrecentchoosermenu.h \
@@ -509,6 +510,7 @@ gtk_base_c_sources = \
gtkrange.c \
gtkrbtree.c \
gtkrc.c \
+ gtkrecentaction.c \
gtkrecentchooserdefault.c \
gtkrecentchooserdialog.c \
gtkrecentchoosermenu.c \