summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-11-06 06:27:01 +0000
committerTor Lillqvist <tml@src.gnome.org>2005-11-06 06:27:01 +0000
commit30edb631342d826c4e4221aaa982d4ed3187a1b3 (patch)
treee52f992623333da128ab569be254d3622d2f42c6 /gtk/Makefile.am
parentbd9e367de7faaee29d326a7a7c4a8eaf99f79d64 (diff)
downloadgtk+-30edb631342d826c4e4221aaa982d4ed3187a1b3.tar.gz
Can't rename a file if the target exists on Win32. First rename the target
2005-11-06 Tor Lillqvist <tml@novell.com> * gtk/updateiconcache.c (build_cache): Can't rename a file if the target exists on Win32. First rename the target temporarily, then if the renaming of the source to target fails, restore the original name for the target. * gtk/Makefile.am: Use EXEEXT in the dependency on gtk-update-icon-cache.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index c567ae9550..74e555cec8 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -953,7 +953,7 @@ STOCK_ICONS = \
icons:
for i in 16 24; do \
- (cd stock-icons/$$i \
+ (cd stock-icons/$$i \
$(LN_S) gtk-go-forward-ltr.png gtk-go-back-rtl.png \
$(LN_S) gtk-go-back-ltr.png gtk-go-forward-rtl.png \
$(LN_S) gtk-goto-first-ltr.png gtk-goto-last-rtl.png \
@@ -966,7 +966,7 @@ icons:
cd ../..) \
done
-gtkbuiltincache.h: @REBUILD@ gtk-update-icon-cache icons
+gtkbuiltincache.h: @REBUILD@ gtk-update-icon-cache$(EXEEXT) icons
./gtk-update-icon-cache --force --ignore-theme-index \
--source builtin_icons stock-icons > gtkbuiltincache.h