summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2012-09-10 13:57:56 +0200
committerBenjamin Otte <otte@redhat.com>2012-09-17 20:39:12 +0200
commit229b6fe17a1c198a1381d905656c23820bfcce94 (patch)
tree91c60f65d22a23df76234e70ee31be509c43a345 /gtk/Makefile.am
parent206aa209ae1e4dffd013a29a06728be81d32ce34 (diff)
downloadgtk+-229b6fe17a1c198a1381d905656c23820bfcce94.tar.gz
css: Add animation support
This adds the GtkCssAnimation class and the code needed to hook it into GtkStyleContext. It takes the values out of the CSS "animation" properties and does animations. See http://dev.w3.org/csswg/css3-animations/ for details. Note that the code for starting and stopping animations with widget visibility doesn't work yet.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 1524b4b503..bb619a4bd7 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -427,6 +427,7 @@ gtk_private_h_sources = \
gtkcolorchooserprivate.h \
gtkcontainerprivate.h \
gtkcssanimatedvaluesprivate.h \
+ gtkcssanimationprivate.h \
gtkcssarrayvalueprivate.h \
gtkcssbgsizevalueprivate.h \
gtkcssbordervalueprivate.h \
@@ -648,6 +649,7 @@ gtk_base_c_sources = \
gtkcomboboxtext.c \
gtkcontainer.c \
gtkcssanimatedvalues.c \
+ gtkcssanimation.c \
gtkcssarrayvalue.c \
gtkcssbgsizevalue.c \
gtkcssbordervalue.c \