summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@gnome.org>2013-01-10 14:36:27 -0600
committerFederico Mena Quintero <federico@gnome.org>2013-01-10 14:36:27 -0600
commitee261203cbf1de122b43d8672c6c52c91b4abcd6 (patch)
tree1f39a30b7f1d0e44072109efc567241d601cd193 /gtk/Makefile.am
parentff041608ec42ac8ec02425c68f91b2ab2ae00280 (diff)
downloadgtk+-ee261203cbf1de122b43d8672c6c52c91b4abcd6.tar.gz
Add a GtkTrashMonitor private API
This is analogous to NautilusTrashMonitor in that it just monitors trash:/// and is able to return the appropriate icon for the trash's current state. Later we may want to move this utility object into GIO or something. Signed-off-by: Federico Mena Quintero <federico@gnome.org>
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 939ffa55f3..110466482c 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -539,6 +539,7 @@ gtk_private_h_sources = \
gtktextutil.h \
gtkthemingbackgroundprivate.h \
gtkthemingengineprivate.h \
+ gtktrashmonitor.h \
gtktoolpaletteprivate.h \
gtktreedatalist.h \
gtktreeprivate.h \
@@ -853,6 +854,7 @@ gtk_base_c_sources = \
gtktoolpalette.c \
gtktoolshell.c \
gtktooltip.c \
+ gtktrashmonitor.c \
gtktreedatalist.c \
gtktreednd.c \
gtktreemenu.c \