summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2014-11-30 15:59:53 -0500
committerMatthias Clasen <mclasen@redhat.com>2014-11-30 16:11:56 -0500
commit383d5b137b0bbf9cd4091e9afa7c0b32339d1652 (patch)
tree5c5529a9fd2c9be32228ad734f457a85acb7b569 /gtk/Makefile.am
parent25d9412c7e4eef9b3fed6177d1741a1cbfbea0cb (diff)
downloadgtk+-383d5b137b0bbf9cd4091e9afa7c0b32339d1652.tar.gz
inspector: Build nonrecursively
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 4301714034..d9f889e879 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -18,7 +18,7 @@ else
GTK_PRINT_PREVIEW_COMMAND="evince --unlink-tempfile --preview --print-settings %s %f"
endif
-SUBDIRS = inspector native .
+SUBDIRS = native .
if OS_DARWIN
ECHO="echo"
else
@@ -122,12 +122,10 @@ endif
libgtkincludedir = $(includedir)/gtk-3.0/gtk
libadd = \
$(top_builddir)/gdk/libgdk-3.la \
- $(top_builddir)/gtk/inspector/libgtkinspector.la \
$(GMODULE_LIBS) \
$(GTK_DEP_LIBS)
deps = \
- $(top_builddir)/gdk/libgdk-3.la \
- $(top_builddir)/gtk/inspector/libgtkinspector.la
+ $(top_builddir)/gdk/libgdk-3.la
# libtool stuff: set version and export symbols for resolving
# since automake doesn't support conditionalized libsomething_la_LDFLAGS
@@ -158,6 +156,7 @@ endif
include $(srcdir)/a11y/Makefile.inc
include $(srcdir)/deprecated/Makefile.inc
+include $(srcdir)/inspector/Makefile.inc
# GTK+ header files for public installation (non-generated, or generated
# by configure)
@@ -394,6 +393,7 @@ gtk_private_type_h_sources = \
# GTK+ header files that don't get installed
gtk_private_h_sources = \
+ $(inspector_h_sources) \
$(gtk_private_type_h_sources) \
gtkactionmuxer.h \
gtkactionobserver.h \
@@ -574,6 +574,7 @@ gtk_private_h_sources = \
gtk_base_c_sources = \
$(a11y_c_sources) \
$(deprecated_c_sources) \
+ $(inspector_c_sources) \
$(clipboard_dnd_c_sources) \
gtkactionmuxer.c \
gtkactionobserver.c \
@@ -1096,6 +1097,7 @@ pkgdata_DATA = gtkbuilder.rng
EXTRA_DIST += gtkbuilder.rnc gtkbuilder.rng
templates = \
+ $(inspector_templates) \
ui/gtkapplication-quartz.ui \
ui/gtkaboutdialog.ui \
ui/gtkactionbar.ui \
@@ -1209,6 +1211,11 @@ gtk.gresource.xml: Makefile.am
$(ECHO) " <file>icons/$$s/actions/$$n</file>" >> $@; \
done; \
done; \
+ for f in $(srcdir)/inspector/*.ui; do \
+ n=`basename $$f`; \
+ $(ECHO) " <file compressed=\"true\">inspector/$$n</file>" >> $@; \
+ done; \
+ $(ECHO) " <file>inspector/logo.png</file>" >> $@; \
$(ECHO) " </gresource>" >> $@; \
$(ECHO) "</gresources>" >> $@;
@@ -1531,6 +1538,7 @@ EXTRA_DIST += \
$(template_headers) \
a11y/Makefile.inc \
deprecated/Makefile.inc \
+ inspector/Makefile.inc \
libgtk3.manifest.in \
gtk-win32.rc.in \
gtkwin32embed.h \