summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2011-05-14 13:27:31 +0200
committerBenjamin Otte <otte@redhat.com>2011-05-18 22:17:55 +0200
commitfc88b0f47c7dc198cc6674cb8819f5b43e45ef3c (patch)
tree3e8fa8c8a3a35ddc0a46db858dfa35a67462eaef /gtk/Makefile.am
parent4e2d3f5d181f84523d3ab13aa18e15a8062dcd1a (diff)
downloadgtk+-fc88b0f47c7dc198cc6674cb8819f5b43e45ef3c.tar.gz
css: Rewrite selectors
Selectors now go into their own C file. The new selectors are modeled a lot closer to the CSS spec. In particular the specificity computation matches CSS 2.1 exactly. For details about the why, see also: http://mail.gnome.org/archives/gtk-devel-list/2011-May/msg00061.html https://bugzilla.gnome.org/show_bug.cgi?id=649798
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index f6758309fe..411193894d 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -388,6 +388,7 @@ gtk_private_h_sources = \
gtkcellareaboxcontextprivate.h \
gtkcssparserprivate.h \
gtkcssproviderprivate.h \
+ gtkcssselectorprivate.h \
gtkcssstringfuncsprivate.h \
gtkcustompaperunixdialog.h \
gtkdndcursors.h \
@@ -515,6 +516,7 @@ gtk_base_c_sources = \
gtkcontainer.c \
gtkcssparser.c \
gtkcssprovider.c \
+ gtkcssselector.c \
gtkcssstringfuncs.c \
gtkdialog.c \
gtkdrawingarea.c \