summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2011-04-27 00:46:52 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2011-04-27 00:48:05 +0800
commit527a299fdd610720a84546863218938d518807e6 (patch)
treec386e8f2e5da73d616f41365db79a65afb9d560e /gtk/Makefile.am
parent343d24c3486a9d04731dcf0538595353f404ded4 (diff)
downloadgtk+-527a299fdd610720a84546863218938d518807e6.tar.gz
Bug 643270: VS2010 Project Files (autotools)
-Update to distribute the VS2010 files. -Added rules in Makefile.am's of GDK and GTK to fill in the project/filter files templates with up-to-date source file listings to simplify maintenace. Any comments on the usage of the VS2010 files are welcome!
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index efe93154b7..0279dec662 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -918,7 +918,7 @@ install-mac-key-theme:
uninstall-mac-key-theme:
endif
-dist-hook: ../build/win32/vs9/gtk.vcproj
+dist-hook: ../build/win32/vs9/gtk.vcproj ../build/win32/vs10/gtk.vcxproj ../build/win32/vs10/gtk.vcxproj.filters
../build/win32/vs9/gtk.vcproj: ../build/win32/vs9/gtk.vcprojin
for F in $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources); do \
@@ -929,6 +929,26 @@ dist-hook: ../build/win32/vs9/gtk.vcproj
done >libgtk.sourcefiles
$(CPP) -P - <$(top_srcdir)/build/win32/vs9/gtk.vcprojin >$@
rm libgtk.sourcefiles
+
+../build/win32/vs10/gtk.vcxproj: ../build/win32/vs10/gtk.vcxprojin
+ for F in $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources); do \
+ case $$F in \
+ *.c) echo ' <ClCompile Include="..\..\..\gtk\'$$F'" />' \
+ ;; \
+ esac; \
+ done >libgtk.vs10.sourcefiles
+ $(CPP) -P - <$(top_srcdir)/build/win32/vs10/gtk.vcxprojin >$@
+ rm libgtk.vs10.sourcefiles
+
+../build/win32/vs10/gtk.vcxproj.filters: ../build/win32/vs10/gtk.vcxproj.filtersin
+ for F in $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources); do \
+ case $$F in \
+ *.c) echo ' <ClCompile Include="..\..\..\gtk\'$$F'"><Filter>Source Files</Filter></ClCompile>' \
+ ;; \
+ esac; \
+ done >libgtk.vs10.sourcefiles.filters
+ $(CPP) -P - <$(top_srcdir)/build/win32/vs10/gtk.vcxproj.filtersin >$@
+ rm libgtk.vs10.sourcefiles.filters
# Install a RC file for the default GTK+ theme, and key themes
install-data-local: install-ms-lib install-def-file install-mac-key-theme