summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2016-10-27 13:39:01 -0400
committerMatthias Clasen <mclasen@redhat.com>2016-11-01 13:58:10 -0400
commit745c348ff8f07815abaf8b437fb5c914f5c60c85 (patch)
treeee664a1884146e663c4c24fd21e9f66122ca0dd7 /gtk/Makefile.am
parent72a9c532620e42f2381b62c592327af5082e6790 (diff)
downloadgtk+-745c348ff8f07815abaf8b437fb5c914f5c60c85.tar.gz
Make GtkTextAttributes private
This is a problematic struct, and giving direct access to it has kept us from making improvements to GtkTextView. Drop it from the public API, together with the auxiliary APIs. If it turns out that this functionality is needed, we should add individual getters.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 8e17336e25..8078bcb68a 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -302,7 +302,6 @@ gtk_public_h_sources = \
gtkstyleprovider.h \
gtkswitch.h \
gtktestutils.h \
- gtktextattributes.h \
gtktextbuffer.h \
gtktextbufferrichtext.h \
gtktextchild.h \
@@ -348,11 +347,6 @@ gtk_unix_print_public_h_sources = \
gtkunixprint.h
endif
-# Installed header files without compatibility guarantees
-# that are not included in gtk/gtk.h
-gtk_semi_private_h_sources = \
- gtktextlayout.h
-
gtk_private_type_h_sources = \
gtkcsstypesprivate.h \
gtktexthandleprivate.h
@@ -553,12 +547,14 @@ gtk_private_h_sources = \
gtkstylepropertyprivate.h \
gtkstyleproviderprivate.h \
gtktextattributesprivate.h \
+ gtktextattributes.h \
gtktextbtree.h \
gtktextbufferprivate.h \
gtktextbufferserialize.h \
gtktextchildprivate.h \
gtktexthandleprivate.h \
gtktextiterprivate.h \
+ gtktextlayout.h \
gtktextmarkprivate.h \
gtktextsegment.h \
gtktexttagprivate.h \
@@ -1364,7 +1360,7 @@ gtktestutils.c: gtktypefuncs.c
lib_LTLIBRARIES = libgtk-4.la
gtkincludedir = $(includedir)/gtk-4.0/gtk
-gtkinclude_HEADERS = $(gtk_public_h_sources) $(gtk_semi_private_h_sources) $(gtk_built_public_sources) gtkversion.h
+gtkinclude_HEADERS = $(gtk_public_h_sources) $(gtk_built_public_sources) gtkversion.h
a11yincludedir = $(includedir)/gtk-4.0/gtk/a11y
a11yinclude_HEADERS= $(a11y_h_sources)