summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2009-08-18 14:34:21 -0400
committerJohan Dahlin <johan@gnome.org>2009-12-16 17:22:00 -0200
commit78758d43ea1c2d3e87050eae078e679281d09106 (patch)
treea5b45163cb39757aa17b9a144aa73aebcc0fab32 /gtk/Makefile.am
parent6e73be9d6cba117196595c015509b3380f57ea4e (diff)
downloadgtk+-78758d43ea1c2d3e87050eae078e679281d09106.tar.gz
Build introspection data for gdk-pixbuf, gdk, and gtk
Generate .gir and .typelib files for gdk-pixbuf, gdk, and gtk. https://bugzilla.gnome.org/show_bug.cgi?id=592279
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 7114da8a13..2b51a3f18e 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -961,6 +961,40 @@ LDADDS = \
$(top_builddir)/gdk-pixbuf/libgdk_pixbuf-$(GTK_API_VERSION).la \
$(top_builddir)/gdk/$(gdktargetlib)
+if HAVE_INTROSPECTION
+BUILT_GIRSOURCES =
+
+Gtk-2.0.gir: $(INTROSPECTION_SCANNER) $(gtktargetlib) Makefile
+ $(INTROSPECTION_SCANNER) -v \
+ --namespace Gtk --nsversion=2.0 --strip-prefix=Gtk \
+ $(INCLUDES) \
+ --add-include-path=../gdk \
+ --add-include-path=../gdk-pixbuf \
+ --include=Gdk-2.0 \
+ --include=Atk-1.0 \
+ --library=$(gtktargetlib) \
+ --libtool="$(LIBTOOL)" \
+ --output $@ \
+ -UGDK_DISABLE_DEPRECATED \
+ -UGTK_DISABLE_DEPRECATED \
+ -DGTK_TEXT_USE_INTERNAL_UNSUPPORTED_API \
+ $(gtkinclude_HEADERS) \
+ $(gtk_all_c_sources) gtktypebuiltins.h gtktypebuiltins.c
+BUILT_GIRSOURCES += Gtk-2.0.gir
+
+girdir = $(datadir)/gir-1.0
+gir_DATA = $(BUILT_GIRSOURCES)
+
+typelibsdir = $(libdir)/girepository-1.0/
+
+typelibs_DATA = $(BUILT_GIRSOURCES:.gir=.typelib)
+
+%.typelib: %.gir $(INTROSPECTION_COMPILER)
+ $(INTROSPECTION_COMPILER) --includedir=$(srcdir) --includedir=. --includedir=../gdk-pixbuf --includedir=../gdk $(INTROSPECTION_COMPILER_OPTS) $< -o $(@F)
+
+CLEANFILES += $(BUILT_GIRSOURCES) $(typelibs_DATA)
+endif
+
#
# Installed tools
#