summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorErik van Pienbroek <epienbro@fedoraproject.org>2012-08-27 22:18:29 +0200
committerMatthias Clasen <mclasen@redhat.com>2012-08-30 21:19:13 -0400
commit9d3c8122f1f72c36f9b5cb5caa0586b4514fdb80 (patch)
treebd5000bb7d88290339ec78d38a2b83b4f3caabbf /gtk/Makefile.am
parent9fa1b4f65fd7c97be5122109230b757707061b19 (diff)
downloadgtk+-9d3c8122f1f72c36f9b5cb5caa0586b4514fdb80.tar.gz
Also compile gtkdbusgenerated.c on non-UNIX environments
When compiling gtk on Win32 then the file gtkdbusgenerated.c also needs to be compiled and linked into the gtk library as it's needed for GtkMountOperation https://bugzilla.gnome.org/show_bug.cgi?id=682825
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 4981db0f64..5bcefd22fd 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -900,6 +900,8 @@ gtk_private_h_sources += \
gtkprinteroptionwidget.h \
gtksearchenginetracker.h
gtk_c_sources += $(gtk_os_unix_c_sources)
+else
+gtk_c_sources += $(gtk_dbus_built_sources)
endif
gtk_os_win32_c_sources = \