summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorTomas Bzatek <tbzatek@redhat.com>2012-07-16 17:29:01 +0200
committerMatthias Clasen <mclasen@redhat.com>2012-07-16 14:28:22 -0400
commitbdc6395d648708d4948dfb654af9947033c953ac (patch)
tree69927e98dc4aeec3cbc9abb74b5d74bb1f076f88 /gtk/Makefile.am
parentad2dc27dd5f505a830c779fb051850fb5922a573 (diff)
downloadgtk+-bdc6395d648708d4948dfb654af9947033c953ac.tar.gz
New gtk-launch command
This program launches an application specified by its desktop name optinally taking list of URIs which are passed as arguments. Uses GdkAppLaunchContext to get proper startup notification and display handling for graphical apps. https://bugzilla.gnome.org/show_bug.cgi?id=679342
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 41c61b86d1..397fa4fa25 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1286,7 +1286,8 @@ endif
# Installed tools
#
bin_PROGRAMS = \
- gtk-query-immodules-3.0
+ gtk-query-immodules-3.0 \
+ gtk-launch
if BUILD_ICON_CACHE
bin_PROGRAMS += gtk-update-icon-cache
@@ -1333,6 +1334,9 @@ gtk_update_icon_cache_LDADD = $(GDK_PIXBUF_LIBS)
gtk_update_icon_cache_SOURCES = updateiconcache.c
endif
+gtk_launch_LDADD = $(LDADDS)
+gtk_launch_SOURCES = gtk-launch.c
+
.PHONY: files test test-debug
files: