summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2019-02-10 12:46:57 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2019-02-14 17:06:49 +0000
commit6058495f50d0f65fbb6d2dcd31d24d0b2ada3194 (patch)
tree9f1ffe0f52755de444b45ef663baa8e829b8789f /gtk/Makefile.am
parent68a7da71e32187dad70fb5913f20bff6e8476ec8 (diff)
downloadgtk+-6058495f50d0f65fbb6d2dcd31d24d0b2ada3194.tar.gz
Use C locale when building gtktypefuncs.c
We're using [a-z] ranges with sed and grep, and POSIX does not specify their behaviour in non-ASCII locales: In the POSIX locale, a range expression represents the set of collating elements that fall between two elements in the collation sequence, inclusive. In other locales, a range expression has unspecified behavior -- IEEE Std 1003.1-2017, ยง 9.3.5 (7) This can lead to no results, or invalid replacements, which in turn can lead to broken builds or broken build artifacts. Fixes: #1662
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index b27ddcc72a..bd20ae409d 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1445,7 +1445,8 @@ gtkprivatetypebuiltins.c: $(gtk_private_type_h_sources) gtkprivatetypebuiltins.
gtktypefuncs.c: stamp-gtktypebuiltins.h stamp-gtkprivatetypebuiltins.h $(top_srcdir)/gtk/*.h $(top_srcdir)/gtk/a11y/*.h $(top_srcdir)/gtk/deprecated/*.h $(top_srcdir)/gdk/*.h Makefile
- $(AM_V_GEN) (echo '#undef GTK_COMPILATION' && echo '#include <gtk/gtkx.h>') > xgen-gtfsrc.c && \
+ $(AM_V_GEN) export LC_ALL=C ; \
+ (echo '#undef GTK_COMPILATION' && echo '#include <gtk/gtkx.h>') > xgen-gtfsrc.c && \
echo 'G_GNUC_BEGIN_IGNORE_DEPRECATIONS' > xgen-gtf && \
${CPP} $(DEFS) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) xgen-gtfsrc.c | \
$(GREP) -o '\bg[td]k_[a-zA-Z0-9_]*_get_type\b' | \