summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <owt1@cornell.edu>1998-03-05 06:32:42 +0000
committerOwen Taylor <otaylor@src.gnome.org>1998-03-05 06:32:42 +0000
commitba55b3f94ba99f24b424c879eaeafe47b932f189 (patch)
tree279b8b989d63267fa2290262bff6d97289a21512 /gtk/Makefile.am
parent793a130520350f91d3b2c42956b596eb13824f41 (diff)
downloadgtk+-ba55b3f94ba99f24b424c879eaeafe47b932f189.tar.gz
Unset allocation on unparent, to force reallocation if we get adding back
Thu Mar 5 01:22:06 1998 Owen Taylor <owt1@cornell.edu> * gtk/gtkwidget.c (gtk_widget_unparent): Unset allocation on unparent, to force reallocation if we get adding back to a new parent which is already size-allocated. * gtk/gtktreeitem.c: Keep track of separate +/- pixmaps for each colormap, removed the idle hack. * gdk/gdk.c: Don't warn when unable to open XIM method, since X11R5 apparently has no default method. * gtk/gtkwidget.c (gtk_widget_set_style_internal): Don't call size_request on initial emission - since the widget size isn't set yet, it can't change. * gtk/Makefile.am: New rules 'test' and 'test-debug' to run testgtk with the correct working directory. * gtk/gtkentry.c (gtk_move_forward_word): Check for position at end of line. * gtk/gtkinputdialog.h (struct _GtkInputDialogClass): removed 'gpointer data' arguments from default handler structures.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 6892253c4c..7301b04ca1 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -269,3 +269,9 @@ files:
@files=`ls $(DISTFILES) 2> /dev/null `; for p in $$files; do \
echo $$p; \
done
+
+test: testgtk
+ ( CWD=`pwd` ; cd $(srcdir) ; $$CWD/testgtk )
+
+test-debug: testgtk
+ ( CWD=`pwd` ; cd $(srcdir) ; gdb $$CWD/testgtk )