summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2013-08-02 17:05:57 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2013-08-02 17:05:57 +0800
commitca2dea0a5a443d1ecbf90830cfeb19eb21ad478a (patch)
treecdbfc6a76edac9ff64c13efe2dddb3ea667693b7 /gtk/Makefile.am
parentdcb766c4617d874588de5edf397ddac017b8d760 (diff)
downloadgtk+-ca2dea0a5a443d1ecbf90830cfeb19eb21ad478a.tar.gz
Add Visual Studio 2010 Build Support for Broadway
Add the Visual Studio 2010 projects to build the GDK Broadway backend, just like the Visual Studio 2008 project files in the last commit. Similarly, split up the property sheets so that they are easier to maintain and can be made more flexible for different build types. Also remove some unneeded stuff from some of these items. Also, fix the filter file completion for GTK, as a source file was excluded for that and this was overlooked as it seemingly did not cause any trouble.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 457f57b9cc..b267d1d5fe 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1279,7 +1279,7 @@ dist-hook: ../build/win32/vs9/gtk.vcproj ../build/win32/vs10/gtk.vcxproj ../buil
rm libgtk.vs10.sourcefiles
../build/win32/vs10/gtk.vcxproj.filters: ../build/win32/vs10/gtk.vcxproj.filtersin
- for F in `echo $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources) | tr '/' '\\'`; do \
+ for F in `echo $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources) $(gtk_dbus_built_sources) | tr '/' '\\'`; do \
case $$F in \
*.c) echo ' <ClCompile Include="..\..\..\gtk\'$$F'"><Filter>Source Files</Filter></ClCompile>' \
;; \