summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorTimm Bäder <mail@baedert.org>2017-04-22 20:18:17 +0200
committerTimm Bäder <mail@baedert.org>2017-04-25 20:30:37 +0200
commit066c1983ba2c6f1f891e600c561ab03eac2074a6 (patch)
treeb3bd68d270eb6ade9f463f615ab7c4e92c59df2d /gtk/Makefile.am
parentc92b7d4224b9cef1d08373fcc28f7fbd96c64e6d (diff)
downloadgtk+-066c1983ba2c6f1f891e600c561ab03eac2074a6.tar.gz
actionbar: Add explicit center widget
The center widget in GtkBox was only introduced to use it in GtkActionBar. However, the implementation there is much more complex than it needs to be, so move the center widget into GtkActionBar instead and later remove it from GtkBox.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index f66e20b4c5..df660307e8 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -576,7 +576,8 @@ gtk_private_h_sources = \
gtkwindowprivate.h \
gtktreemenu.h \
gdkpixbufutilsprivate.h \
- gtkgizmoprivate.h
+ gtkgizmoprivate.h \
+ gtkcenterboxprivate.h
# GTK+ C sources to build the library from
gtk_base_c_sources = \
@@ -939,7 +940,8 @@ gtk_base_c_sources = \
gtkwin32draw.c \
gtkwin32theme.c \
gdkpixbufutils.c \
- gtkgizmo.c
+ gtkgizmo.c \
+ gtkcenterbox.c
if USE_QUARTZ
gtk_base_c_sources += \