summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-11-11 16:31:53 +0100
committerMatthias Clasen <mclasen@redhat.com>2016-07-08 00:07:42 -0400
commit01d0bac83e7f12338d12e5669c408da3078f6010 (patch)
treeacb09d092a909dd84f5ef9b777c5723421a98cb8 /gtk/Makefile.am
parente47957406d60345efa624dea6517f7d793fc1a13 (diff)
downloadgtk+-01d0bac83e7f12338d12e5669c408da3078f6010.tar.gz
Initial version of file chooser portal support
Implement GtkFileChooserNative for sandboxed applications by talking to org.freedesktop.portal.FileChooser. Currently, this supports OPEN and SAVE mode. https://bugzilla.gnome.org/show_bug.cgi?id=768499
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 2f05cbbdd7..966a60bfcb 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -753,6 +753,7 @@ gtk_base_c_sources = \
gtkfilechooserembed.c \
gtkfilechooserentry.c \
gtkfilechoosernative.c \
+ gtkfilechoosernativeportal.c \
gtkfilechooserutils.c \
gtkfilechooserwidget.c \
gtkfilefilter.c \