summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorJohn Ralls <jralls@ceridwen.us>2013-05-03 10:31:47 -0700
committerJohn Ralls <jralls@ceridwen.us>2013-05-20 15:44:18 -0700
commitffd538c8025930ce96bb75da42a74fb3c160bea8 (patch)
tree5bb87e314e92765e4514fdc54267388a7b2983a0 /gtk/Makefile.am
parentaf1499c37133d9fdd236f3edc9720a2cd733bd2a (diff)
downloadgtk+-ffd538c8025930ce96bb75da42a74fb3c160bea8.tar.gz
Bug 667759 - gtkdnd-quartz.c is missing annotations for introspection
Work around this by introspecting gtkclipboard.c and gtkdnd.c instead of the quartz alternatives. Note that this is temporary: The implementation of GdkSelection will make the quartz alternatives unnecessary. See bug 571582.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index a726377f18..dafebe6e06 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1308,13 +1308,24 @@ LDADDS = \
$(GTK_DEP_LIBS)
if HAVE_INTROSPECTION
+# The Quartz clipboard and dnd files aren't annotated for
+# introspection. Rather than copy the annotations over from the
+# regular files, exclude the quartz ones:
introspection_files = \
$(filter-out %private.h gtktextdisplay.h gtktextlayout.h, $(gtkinclude_HEADERS) $(deprecatedinclude_HEADERS)) \
- $(gtk_base_c_sources) \
+ $(filter-out gtkclipboard-quartz.c gtkdnd-quartz.c, \
+ $(gtk_base_c_sources)) \
gtkprintoperation-unix.c \
gtktypebuiltins.h \
gtktypebuiltins.c
+# And include the regular ones:
+if USE_QUARTZ
+introspection_files += \
+ gtkclipboard.c \
+ gtkdnd.c
+endif
+
if USE_X11
introspection_files += \
gtksocket.c \