summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2013-05-02 16:23:42 +0200
committerAlexander Larsson <alexl@redhat.com>2013-05-07 16:34:05 +0200
commit30dc399b724629053cee044a45d8f55b0ae9c7a2 (patch)
treef429c5c54dd309771e73967f97631de44838c522 /gtk/Makefile.am
parentcb2882a273a380bd022b6a7adfc064c5bf04081a (diff)
downloadgtk+-30dc399b724629053cee044a45d8f55b0ae9c7a2.tar.gz
Add GtkPixelCache
GtkPixelCache is a helper utility that lets you implement faster scrolling of a viewport of a canvas by using an offscreen pixmap cache. You call _gtk_pixel_cache_draw with a callback function that does the drawing, and additionally you specify the size and the position of the viewport in the widget, and the position and size of the canvas wrt the viewport. The callback will be called to draw on an offscreen surface, and the surface will be drawn on the window. The next time you do the same, any already drawn pieces of the surface are re-used from the offscreen and need not be rendered again. If things inside the canvas change you need to call _gtk_pixel_cache_invalidate to tell the cache about this. Some other details: * The offscreen surface is generally a bit larger than the viewport, so scrolling a small amount can often be done without redrawing children. * If the canvas is not larger than the viewport no offscreen surface is used. GtkPixelCache: Make sure we always copy using SOURCE We were using OVER for the first copy (from source to group surface. GtkPixelCache: Fix x/y typos GtkPixelCache: Allow NULL for invalidate region gtkpixelcache: Use CONTENT_COLOR for solid bg windows
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index ad3f711020..87c920f981 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -515,6 +515,7 @@ gtk_private_h_sources = \
gtkprintoperation-private.h \
gtkprintutils.h \
gtkprivate.h \
+ gtkpixelcacheprivate.h \
gtkquery.h \
gtkrbtree.h \
gtkrecentchooserdefault.h \
@@ -796,6 +797,7 @@ gtk_base_c_sources = \
gtkprivate.c \
gtkprivatetypebuiltins.c \
gtkprogressbar.c \
+ gtkpixelcache.c \
gtkradioaction.c \
gtkradiobutton.c \
gtkradiomenuitem.c \