summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorKristian Rietveld <kris@imendio.com>2007-02-06 10:25:21 +0000
committerKristian Rietveld <kristian@src.gnome.org>2007-02-06 10:25:21 +0000
commit0ef946ed64c746aa210f40884d5e082e9c3a6d01 (patch)
treee2e71072af6204dece9abb6a1892507065d66952 /gtk/Makefile.am
parent47b8d98aba689af51337f34fe54ceb5e8390bfd1 (diff)
downloadgtk+-0ef946ed64c746aa210f40884d5e082e9c3a6d01.tar.gz
New tooltips API.
2007-02-06 Kristian Rietveld <kris@imendio.com> New tooltips API. * gtk/Makefile.am * gtk/gtk.h * gtk/gtk.symbols: build system foo. * gtk/gtkmain.c (gtk_main_do_event): call tooltip event handler hook for appropriate events. * gtk/gtkmarshalers.list: add BOOLEAN:INT,INT,BOOLEAN,OBJECT. * gtk/gtkrc.c: add style for gtk-tooltip. * gtk/gtksettings.c (gtk_settings_class_init): make the different tooltip timeouts configurable. * gtk/gtkwidget.[ch]: add new properties, signals, make sure tooltips are hidden on unmap, destroy, update window event mask on realize, hook into focus change and show help handlers. * gtk/gtkwindow.h: move GtkWindow typdef to gtkwidget.h ... * gtk/gtktooltip.[ch]: new files. * tests/Makefile.am * tests/testtooltips.c: add test application. svn path=/trunk/; revision=17264
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 749b7ff8f5..b212d62ed7 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -292,6 +292,7 @@ gtk_public_h_sources = \
gtktoolbar.h \
gtktoolbutton.h \
gtktoolitem.h \
+ gtktooltip.h \
gtktooltips.h \
gtktree.h \
gtktreednd.h \
@@ -559,6 +560,7 @@ gtk_base_c_sources = \
gtktoolbar.c \
gtktoolbutton.c \
gtktoolitem.c \
+ gtktooltip.c \
gtktooltips.c \
gtktree.c \
gtktreedatalist.c \