summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2010-09-21 16:52:59 +0200
committerBenjamin Otte <otte@redhat.com>2010-09-26 15:11:45 +0200
commite66129015de47d21006ff03f82964a77fdf7ca3d (patch)
tree744cd6f0f36d8216ebeef9c7a52cd0550f695122 /gtk/Makefile.am
parentd9c92598612714683eab96fecf6e90a9531607e5 (diff)
downloadgtk+-e66129015de47d21006ff03f82964a77fdf7ca3d.tar.gz
cellrenderer: Merge GtkCellSizeRequest into GtkCellRenderer
This mostly goes to keep consistency with the changes to GtkSizeRequest in the last patch, as GtkCellSizeRequest requires GtkCellRenderer and GtkCellRenderer implements GtkCellSizeRequest there's no use in keeping them separate. This patch renames the functions: gtk_cell_size_request_get_request_mode() => gtk_cell_renderer_get_request_mode() gtk_cell_size_request_get_width() => gtk_cell_renderer_get_preferred_width() gtk_cell_size_request_get_height() => gtk_cell_renderer_get_preferred_height() gtk_cell_size_request_get_size() => gtk_cell_renderer_get_preferred_size() gtk_cell_size_request_get_width_for_height() => gtk_cell_renderer_get_preferred_width_for_height() gtk_cell_size_request_get_height_for_width() => gtk_cell_renderer_get_preferred_height_for_width() ... and moves the corresponding vfuncs to GtkCellRenderer. The patch also renames the implementations of these functions in cell renderers to include the word "preferrred".
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 15397d3671..60057e575f 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -179,7 +179,6 @@ gtk_public_h_sources = \
gtkcellrendererspinner.h\
gtkcellrenderertext.h \
gtkcellrenderertoggle.h \
- gtkcellsizerequest.h \
gtkcellview.h \
gtkcheckbutton.h \
gtkcheckmenuitem.h \
@@ -440,7 +439,6 @@ gtk_base_c_sources = \
gtkcellrendererspinner.c\
gtkcellrenderertext.c \
gtkcellrenderertoggle.c \
- gtkcellsizerequest.c \
gtkcellview.c \
gtkcheckbutton.c \
gtkcheckmenuitem.c \