summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2010-03-21 18:24:24 +0200
committerTor Lillqvist <tml@iki.fi>2010-04-12 12:45:40 +0300
commite5446020650ad9d3a00f68c5e4a3276bef685178 (patch)
treef9630b1db5fe5968a202500a71715cb770221840 /gtk/Makefile.am
parent8d17d157ba815659d187a5f51e88b11075f944f6 (diff)
downloadgtk+-e5446020650ad9d3a00f68c5e4a3276bef685178.tar.gz
Add Visual Studio 2008 project files
Similar setup as in GLib and Pango. Also here we use a build/win32/vs9 subfolder, even if there is nothing else in build or build/win32.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index f96c35e181..e05129fdbf 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -646,9 +646,9 @@ gtk_public_h_sources += \
gtkclist.h \
gtkcombo.h \
gtkctree.h \
- gtkcurve.h \
+ gtkcurve.h \
gtkfilesel.h \
- gtkgamma.h \
+ gtkgamma.h \
gtkinputdialog.h \
gtkitemfactory.h \
gtklist.h \
@@ -943,6 +943,18 @@ install-mac-key-theme:
uninstall-mac-key-theme:
endif
+dist-hook: ../build/win32/vs9/gtk.vcproj
+
+../build/win32/vs9/gtk.vcproj: ../build/win32/vs9/gtk.vcprojin
+ for F in $(gtk_base_c_sources) $(gtk_os_win32_c_sources) $(gtk_use_win32_c_sources); do \
+ case $$F in \
+ *.c) echo ' <File RelativePath="..\..\..\gtk\'$$F'" />' \
+ ;; \
+ esac; \
+ done >libgtk.sourcefiles
+ $(CPP) -P - <$(top_srcdir)/build/win32/vs9/gtk.vcprojin >$@
+ rm libgtk.sourcefiles
+
# Install a RC file for the default GTK+ theme, and key themes
install-data-local: install-ms-lib install-def-file install-mac-key-theme
$(mkinstalldirs) $(DESTDIR)$(datadir)/themes/Raleigh/gtk-2.0