summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorCarlos Soriano <csoriano@gnome.org>2015-05-06 23:07:17 +0200
committerCarlos Soriano <csoriano@gnome.org>2015-06-16 16:19:37 +0200
commitfbbad5deecb635af34a890a540e8e272b95c4d9b (patch)
tree90289307eaecc1d91065d3088a5c12c05619bcc1 /gtk/Makefile.am
parentd881b1534914398046f7e5237321f978ff073441 (diff)
downloadgtk+-fbbad5deecb635af34a890a540e8e272b95c4d9b.tar.gz
gtkplacesidebar: use GtkListBox
We were using GTkTreeView in a simple list. Also, as we know, GtkCellRenderers are not the best way to theme and manipulate widgets. So instead use a GtkListBox to modernize the GtkPlacesSidebar, and in the way clean up some parts of the code (like headings) which were not used anymore. Also we don't use a model anymore, since the data is simple enough to manage it in a subclass of the row itself.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 72ee47fdff..50e8efb21f 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -474,6 +474,7 @@ gtk_private_h_sources = \
gtkorientableprivate.h \
gtkpango.h \
gtkpathbar.h \
+ gtkplacessidebarprivate.h \
gtkpopoverprivate.h \
gtkprintoperation-private.h \
gtkprintutils.h \
@@ -496,6 +497,7 @@ gtk_private_h_sources = \
gtksearchenginesimple.h \
gtksearchentryprivate.h \
gtkselectionprivate.h \
+ gtksidebarrowprivate.h \
gtksettingsprivate.h \
gtksizegroup-private.h \
gtksizerequestcacheprivate.h \
@@ -793,6 +795,7 @@ gtk_base_c_sources = \
gtkseparatormenuitem.c \
gtkseparatortoolitem.c \
gtksettings.c \
+ gtksidebarrow.c \
gtksizegroup.c \
gtksizerequest.c \
gtksizerequestcache.c \
@@ -1086,7 +1089,8 @@ templates = \
ui/gtksearchbar.ui \
ui/gtkscalebutton.ui \
ui/gtkstatusbar.ui \
- ui/gtkvolumebutton.ui
+ ui/gtkvolumebutton.ui \
+ ui/gtksidebarrow.ui
#
# rules to generate built sources