summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-08-23 15:26:49 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-08-23 15:26:49 +0000
commita2d60d44b170d403f26444081113be8d60afe8a3 (patch)
treeda9506d74a6edba8c3fc4232b350eb3263df95b5 /gtk/Makefile.am
parent34852377443196c3b2b6affd18e3ad7f5400cea8 (diff)
downloadgtk+-a2d60d44b170d403f26444081113be8d60afe8a3.tar.gz
[ Patch from Sebastian Wilhelmi, 52790 ]
Wed Aug 22 19:15:39 2001 Owen Taylor <otaylor@redhat.com> [ Patch from Sebastian Wilhelmi, 52790 ] * gtk/gtkversion.h.in gtk/gtk.h: New file replacing gtkcompat.h * gdk/gdkcompat.h gdk/gdk*.h gtk/gtkcompat.h.in gtk/gtk*.h: Move compatibility macros from g[dt]kcompat.h to within #ifndef G[DT]K_DISABLE_DEPRECATED in each file. * gdk/gdk-pixbuf-csource.c: Fix up include of gtkcompat.h. * demos/Makefile.am demos/gtk-demo/Makefile.am docs/reference/gdk-pixbuf/Makefile.am modules/input/Makefile.am tests/Makefile.am: Remove references to -G[DT]K_DISABLE_DEPRECATED. * demos/{pixbuf-demo.c,testpixbuf-drawable.c,testpixbuf-save.c, testpixbuf.c}: Fix usages of deprecated functions.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 0ea53da902..b4124e6a64 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -4,7 +4,6 @@ SUBDIRS=stock-icons
INCLUDES = @STRIP_BEGIN@ \
-DG_LOG_DOMAIN=\"Gtk\" \
- -DGTK_DISABLE_COMPAT_H \
-DGTK_LIBDIR=\"$(libdir)\" \
-DGTK_DATA_PREFIX=\"$(prefix)\" \
-DGTK_SYSCONFDIR=\"$(sysconfdir)\" \
@@ -388,7 +387,7 @@ gtk_built_sources = @STRIP_BEGIN@ \
# that don't serve as direct make target sources, i.e. they don't have
# their own .lo rules and don't get publically installed
gtk_extra_sources = @STRIP_BEGIN@ \
- gtkcompat.h.in \
+ gtkversion.h.in \
maketypes.awk \
makeenums.h \
gtk-boxed.defs \
@@ -399,7 +398,7 @@ gtk_extra_sources = @STRIP_BEGIN@ \
#
# setup GTK+ sources and their dependancies
#
-gtk_target_headers = $(gtk_public_h_sources) $(gtk_built_public_sources) gtkcompat.h
+gtk_target_headers = $(gtk_public_h_sources) $(gtk_built_public_sources) gtkversion.h
gtk_target_sources = $(gtk_c_sources) $(gtk_plug_c_sources)
MAINTAINERCLEANFILES += $(gtk_built_sources)
EXTRA_HEADERS +=