summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2015-04-18 21:03:52 -0400
committerMatthias Clasen <mclasen@redhat.com>2015-04-27 19:10:10 -0400
commit8bb5a149778b90423c3f770e18e67d7b678f76d9 (patch)
treef74056387344caad4eac22dc84e66ed13ba29846 /gtk/Makefile.am
parentfea2e7bf3515e8a850944715a7caf77f33d1b693 (diff)
downloadgtk+-8bb5a149778b90423c3f770e18e67d7b678f76d9.tar.gz
Add a simple commandline tool for ui files
This tool strips properties which are set to their default value from .ui files.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index c59f63e8c1..9e8b2a8ac1 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1391,6 +1391,7 @@ bin_PROGRAMS = \
gtk-query-immodules-3.0 \
gtk-update-icon-cache \
gtk-encode-symbolic-svg \
+ gtk-builder-tool \
gtk-launch
gtk_query_immodules_3_0_SOURCES = queryimmodules.c
@@ -1409,6 +1410,12 @@ gtk_encode_symbolic_svg_LDADD = \
$(top_builddir)/gdk/libgdk-3.la \
$(GTK_DEP_LIBS)
+gtk_builder_tool_SOURCES = gtk-builder-tool.c
+gtk_builder_tool_LDADD = \
+ libgtk-3.la \
+ $(top_builddir)/gdk/libgdk-3.la \
+ $(GTK_DEP_LIBS)
+
gtk_launch_SOURCES = gtk-launch.c
gtk_launch_LDADD = \
libgtk-3.la \