summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2015-10-29 15:06:57 +0100
committerAlexander Larsson <alexl@redhat.com>2015-11-05 16:54:07 +0100
commit5094900180ac97e6bba2f86ee702d0649e019e6a (patch)
tree7527ba2439f350f7c0c75ce7af0c52ff038c9ded /gtk/Makefile.am
parent693db082a158952efd5a326a62814490c3c8f6ad (diff)
downloadgtk+-5094900180ac97e6bba2f86ee702d0649e019e6a.tar.gz
GtkFileChooserNative: Fallback and win32 implementation
This is a subclass on GtkNativeDialog that uses GtkFileChooserDialog as a fallback, but also has support for the win32 file chooser dialog.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 84f3ffe032..db6f55df5e 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -180,6 +180,7 @@ gtk_public_h_sources = \
gtkfilechooser.h \
gtkfilechooserbutton.h \
gtkfilechooserdialog.h \
+ gtkfilechoosernative.h \
gtkfilechooserwidget.h \
gtkfilefilter.h \
gtkfixed.h \
@@ -440,6 +441,7 @@ gtk_private_h_sources = \
gtkfilechooserembed.h \
gtkfilechooserentry.h \
gtkfilechooserprivate.h \
+ gtkfilechoosernativeprivate.h \
gtkfilechooserwidgetprivate.h \
gtkfilechooserutils.h \
gtkfilefilterprivate.h \
@@ -696,6 +698,7 @@ gtk_base_c_sources = \
gtkfilechooserdialog.c \
gtkfilechooserembed.c \
gtkfilechooserentry.c \
+ gtkfilechoosernative.c \
gtkfilechooserutils.c \
gtkfilechooserwidget.c \
gtkfilefilter.c \
@@ -940,6 +943,7 @@ endif
gtk_os_win32_c_sources = \
gtkprint-win32.c \
gtkprintoperation-win32.c \
+ gtkfilechoosernativewin32.c \
gtkwin32.c
if OS_WIN32
gtk_private_h_sources += gtkprint-win32.h