summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2000-09-26 20:22:17 +0000
committerHavoc Pennington <hp@src.gnome.org>2000-09-26 20:22:17 +0000
commite8597130f58f6808cdfa1bac7058da7f33a9f600 (patch)
tree147da1d69e7b52f2139600d9609eb58a1253965d /gtk/Makefile.am
parent9bec105a6606f11fb1e85e5f378d39595da0c165 (diff)
downloadgtk+-e8597130f58f6808cdfa1bac7058da7f33a9f600.tar.gz
Move more text widget headers into the private header list
2000-09-26 Havoc Pennington <hp@redhat.com> * gtk/Makefile.am (gtk_private_h_sources): Move more text widget headers into the private header list * Makefile.am (pkgconfig_DATA): install pkg-config files * configure.in: add pkg-config files * gdk-2.0.pc.in, gdk-pixbuf.pc.in, gtk+-2.0.pc.in: pkg-config files * gtk/gtkwindow.c (gtk_window_read_rcfiles): Invalidate outstanding icon caches on theme change. * gtk/gtkiconfactory.h, gtk/gtkiconfactory.c: New icon system. Three important types: (GtkIconSource): Specification for creating a pixbuf appropriate for a direction/state/size triplet from a source pixbuf or filename (GtkIconSet): List of GtkIconSource objects that are used to create the "same" icon (e.g. an OK button icon), and cache for rendered icons (GtkIconFactory): Hash from stock ID to GtkIconSet; used to look up the icon set for a given stock ID. GTK maintains a stack of GtkIconFactory to search, and applications or libraries can add additional icon factories on top of the stack * gtk/gtkrc.h, gtk/gtkrc.c: When loading an RcStyle, parse the set of GtkIconSource specified for a given stock ID into a GtkIconSet, and put the GtkIconSet into a GtkIconFactory for the RcStyle, under the specified stock ID. * gtk/gtkstyle.h, gtk/gtkstyle.c: Add a virtual function render_icon used to derive a GdkPixbuf from a GtkIconSource. This allows people to theme how prelight, insensitive, etc. are done. (gtk_style_lookup_icon_set): Look up a stock ID in the list of icon factories for a style, and return the resulting icon set if any. (gtk_style_render_icon): Render an icon using the render_icon method in the GtkStyleClass. * gtk/gtkwidget.h, gtk/gtkwidget.c (gtk_widget_render_icon): Use the style for a given widget to look up a stock ID, get the icon set, and render an icon using the render_icon method of the style * gtk/gtkstock.h, gtk/gtkstock.c: Header with the GtkStockItem type (contains information about a stock item), the built-in stock item IDs, and functions to add/lookup stock items. * gtk/stock-icons/*: Stock icons that come with GTK * gtk/gtkbutton.h, gtk/gtkbutton.c (gtk_button_new_stock): Returns a button based on a GtkStockItem (gtk_button_new_accel): Takes a uline string and accel group, and installs the accelerator. * gtk/gtkimage.h, gtk/gtkimage.c: Make this into a generic image-display widget.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 274ecc36ad..173ef56a92 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1,5 +1,7 @@
## Makefile.am for gtk+/gtk
+SUBDIRS=stock-icons
+
INCLUDES = @STRIP_BEGIN@ \
-DG_LOG_DOMAIN=\"Gtk\" \
-DGTK_DISABLE_COMPAT_H \
@@ -96,6 +98,7 @@ gtk_public_h_sources = @STRIP_BEGIN@ \
gtkhscrollbar.h \
gtkhseparator.h \
gtkhsv.h \
+ gtkiconfactory.h \
gtkimage.h \
gtkimcontext.h \
gtkimmulticontext.h \
@@ -141,6 +144,7 @@ gtk_public_h_sources = @STRIP_BEGIN@ \
gtkspinbutton.h \
gtkstyle.h \
gtkstatusbar.h \
+ gtkstock.h \
gtktable.h \
gtktearoffmenuitem.h \
gtktextbuffer.h \
@@ -178,16 +182,18 @@ gtk_public_h_sources = @STRIP_BEGIN@ \
# interface)
gtk_semipublic_h_sources = @STRIP_BEGIN@ \
- gtktextbtree.h \
- gtktextchild.h \
gtktextdisplay.h \
gtktextlayout.h \
- gtktextsegment.h \
- gtktexttypes.h \
@STRIP_END@
# GTK+ header files that don't get installed
gtk_private_h_sources = @STRIP_BEGIN@ \
+ gtktextbtree.h \
+ gtktextchild.h \
+ gtktextsegment.h \
+ gtktexttypes.h \
+ gtktextiterprivate.h \
+ gtktextmarkprivate.h \
gtktexttagprivate.h \
@STRIP_END@
@@ -238,6 +244,7 @@ gtk_c_sources = @STRIP_BEGIN@ \
gtkhscrollbar.c \
gtkhseparator.c \
gtkhsv.c \
+ gtkiconfactory.c \
gtkimage.c \
gtkimcontext.c \
gtkimcontextsimple.c \
@@ -283,6 +290,7 @@ gtk_c_sources = @STRIP_BEGIN@ \
gtksignal.c \
gtksocket.c \
gtkspinbutton.c \
+ gtkstock.c \
gtkstyle.c \
gtkstatusbar.c \
gtktable.c \