summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2007-05-02 22:51:43 +0000
committerEmmanuele Bassi <ebassi@src.gnome.org>2007-05-02 22:51:43 +0000
commitd3aeccf774fd13c4efdbdb873bb2258e1b94f853 (patch)
tree4ce2f324a2518663451f7e82cb0d9da97b7ee5b2 /gtk/Makefile.am
parente82e337ee915d0cb1f07640be53a76854684b181 (diff)
downloadgtk+-d3aeccf774fd13c4efdbdb873bb2258e1b94f853.tar.gz
Add search file support in the GtkFileChooser. Original patch by Federico
2007-05-02 Emmanuele Bassi <ebassi@gnome.org> Add search file support in the GtkFileChooser. Original patch by Federico Mena Quintero; patch updated by Matthias Clasen. See bug #344785. * gtk/gtksearchengine.[ch]: Private search engine abstraction object. * gtk/gtksearchenginebeagle.[ch]: Private search engine implementation using libbeagle (via g_module_open()). * gtk/gtksearchenginesimple.[ch]: Private search engine implementation using file tree walking. * gtk/gtksearchenginetracker.[ch]: Private earch engine implementation using libtracker (via g_module_open()). * gtk/gtkquery.[ch]: Private query object for the search engines. * gtk/gtkfilechooserprivate.h: * gtk/gtkfilechooserdefault.c: Use the GtkSearchEngine to query a search engine backend using GtkQuery; create a new operating mode, OPERATION_MODE_SEARCH, and call the common operating mode OPERATION_MODE_BROWSE; add support for virtual shortcuts inside the shortcuts model and create a new "Search" virtual shortcut. * gtk/Makefile.am: Update the build with the new files svn path=/trunk/; revision=17783
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 4a5b0764e1..3097d20544 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -335,6 +335,11 @@ gtk_semi_private_h_sources = \
# GTK+ header files that don't get installed
gtk_private_h_sources = \
+ gtkquery.h \
+ gtksearchengine.h \
+ gtksearchenginebeagle.h \
+ gtksearchenginetracker.h\
+ gtksearchenginesimple.h \
gtkdndcursors.h \
gtkentryprivate.h \
gtkfilechooserdefault.h \
@@ -376,6 +381,11 @@ gtk_private_h_sources = \
# GTK+ C sources to build the library from
gtk_base_c_sources = \
+ gtkquery.c \
+ gtksearchengine.c \
+ gtksearchenginebeagle.c \
+ gtksearchenginetracker.c\
+ gtksearchenginesimple.c \
fnmatch.c \
gtkaboutdialog.c \
gtkaccelgroup.c \