summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garnacho <carlos@imendio.com>2008-06-10 00:39:45 +0000
committerCarlos Garnacho <carlosg@src.gnome.org>2008-06-10 00:39:45 +0000
commitafb46bc3825c43c70534fa42a7254b5a50928667 (patch)
tree05a655b0a322be94ebb84264dcc89c91fbdecdfe /gtk/Makefile.am
parent640d68778a82ae1c338d1583af49120c7119e3ae (diff)
downloadgtk+-afb46bc3825c43c70534fa42a7254b5a50928667.tar.gz
removed local xdgmime copy as Matthias suggested in bug #520874, comment
2008-06-10 Carlos Garnacho <carlos@imendio.com> * configure.in: * gtk/Makefile.am: * gtk/xdgmime: removed local xdgmime copy as Matthias suggested in bug #520874, comment #8. It's no longer used directly by GTK+. svn path=/trunk/; revision=20343
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 9af44121c8..714badfedd 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1,19 +1,14 @@
# Makefile.am for gtk+/gtk
include $(top_srcdir)/Makefile.decl
-xdgmimedir =
-
-if OS_UNIX
-xdgmimedir += xdgmime
if USE_QUARTZ
GTK_PRINT_PREVIEW_COMMAND="open -a /Applications/Preview.app %f"
else
GTK_PRINT_PREVIEW_COMMAND="evince --unlink-tempfile --preview --print-settings %s %f"
endif
-endif
-SUBDIRS = theme-bits $(xdgmimedir) . tests
-DIST_SUBDIRS=theme-bits xdgmime tests
+SUBDIRS = theme-bits . tests
+DIST_SUBDIRS=theme-bits tests
if HAVE_CUPS
GTK_PRINT_BACKENDS=file,cups
@@ -116,10 +111,6 @@ libadd = \
$(GTK_DEP_LIBS)
deps =
-if OS_UNIX
-libadd += xdgmime/libxdgmime.la
-endif
-
# libtool stuff: set version and export symbols for resolving
# since automake doesn't support conditionalized libsomething_la_LDFLAGS
# we use the general approach here