summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorMathias Hasselmann <hasselmm@src.gnome.org>2007-12-14 10:57:46 +0000
committerMathias Hasselmann <hasselmm@src.gnome.org>2007-12-14 10:57:46 +0000
commit95adf7ee26a5c113ef63805842578254789c06e9 (patch)
treefbec6dfbe1662b816a7164009766332b4446f963 /gtk/Makefile.am
parentea8074a4077ac7bf90f3873160da35bd491e8079 (diff)
downloadgtk+-95adf7ee26a5c113ef63805842578254789c06e9.tar.gz
Change GtkToolItem to retrieve its properties from GtkToolShell interface,
instead of relying on being child of a GtkToolbar. (#5034079) * gtk/gtk.symbols, docs/reference/gtk/gtk-docs.sgml, docs/reference/gtk/gtk-sections.txt: Add GtkToolShell symbols. * docs/reference/gtk/tmpl/gtktoolitem.sgml: Move section docs inline. * gtk/gtktoolbar.c: Implement GtkToolShellIface. * gtk/gtktoolbar.h: Remove _gtk_toolbar_rebuild_menu. * gtk/gtktoolitem.c: Use GtkToolShell, instead of GtkToolbar. Take section docs from template file and update them for GtkToolShell. * gtk/Makefile.am: Add gtk/gtktoolshell.c and gtk/gtktoolshell.h. * gtk/gtktoolshell.c, gtk/gtktoolshell.h: New GtkToolShellIface. svn path=/trunk/; revision=19177
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 359d1c9cda..5a19467b55 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -299,6 +299,7 @@ gtk_public_h_sources = \
gtktoolbar.h \
gtktoolbutton.h \
gtktoolitem.h \
+ gtktoolshell.h \
gtktooltip.h \
gtktooltips.h \
gtktree.h \
@@ -587,6 +588,7 @@ gtk_base_c_sources = \
gtktoolbar.c \
gtktoolbutton.c \
gtktoolitem.c \
+ gtktoolshell.c \
gtktooltip.c \
gtktooltips.c \
gtktree.c \