summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorSven Neumann <sven@gimp.org>2008-02-27 09:58:49 +0000
committerSven Neumann <neo@src.gnome.org>2008-02-27 09:58:49 +0000
commit1d7a62a2cd09bda9ef798fcd95a5e4cbe6b865b0 (patch)
treeb809e408de327d87acd358083a40f342a3f6154f /gtk/Makefile.am
parent2b66e18dab44e1f207c881078a3230569bd3b927 (diff)
downloadgtk+-1d7a62a2cd09bda9ef798fcd95a5e4cbe6b865b0.tar.gz
when building the Quartz backend, use a native Mac OS X application for
2008-02-27 Sven Neumann <sven@gimp.org> * gtk/Makefile.am (GTK_PRINT_PREVIEW_COMMAND): when building the Quartz backend, use a native Mac OS X application for the print preview (bug #518624). svn path=/trunk/; revision=19663
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index fe08407465..9bf76e736c 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -5,8 +5,12 @@ xdgmimedir =
if OS_UNIX
xdgmimedir += xdgmime
+if USE_QUARTZ
+GTK_PRINT_PREVIEW_COMMAND="/Applications/Preview.app/Contents/MacOS/Preview %f"
+else
GTK_PRINT_PREVIEW_COMMAND="evince --unlink-tempfile --preview --print-settings %s %f"
endif
+endif
SUBDIRS = theme-bits $(xdgmimedir) . tests
DIST_SUBDIRS=theme-bits xdgmime tests