summaryrefslogtreecommitdiff
path: root/gsk/vulkan/resources/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2023-05-16 17:25:17 +0000
committerMatthias Clasen <mclasen@redhat.com>2023-05-16 17:25:17 +0000
commit4efc736a6ee9fdff0132b0f9b66a72c2989751cf (patch)
treed40d532bc6dcd8f330acd08ae4fa7fd6e941b427 /gsk/vulkan/resources/meson.build
parent4a1598dc2a316eb27046467a33c68ff1babb55fa (diff)
parent2b0e3a5b1a595c5c8463706452637c3ed716e0c8 (diff)
downloadgtk+-4efc736a6ee9fdff0132b0f9b66a72c2989751cf.tar.gz
Merge branch 'wip/otte/for-main' into 'main'
gdk: Clamp frame region to surface size Closes #5812 See merge request GNOME/gtk!5976
Diffstat (limited to 'gsk/vulkan/resources/meson.build')
-rw-r--r--gsk/vulkan/resources/meson.build16
1 files changed, 9 insertions, 7 deletions
diff --git a/gsk/vulkan/resources/meson.build b/gsk/vulkan/resources/meson.build
index 3486a8868b..86e98acb9e 100644
--- a/gsk/vulkan/resources/meson.build
+++ b/gsk/vulkan/resources/meson.build
@@ -1,10 +1,9 @@
-# FIXME: what's up with these?
-#gsk_private_vulkan_include_shaders = [
-# 'clip.frag.glsl',
-# 'clip.vert.glsl',
-# 'constants.glsl',
-# 'rounded-rect.glsl',
-#]
+gsk_private_vulkan_include_shaders = [
+ 'clip.frag.glsl',
+ 'clip.vert.glsl',
+ 'constants.glsl',
+ 'rounded-rect.glsl',
+]
gsk_private_vulkan_fragment_shaders = [
'blendmode.frag',
@@ -51,6 +50,7 @@ foreach shader: gsk_private_vulkan_shaders
compiled_shader = custom_target(spv_shader,
input: shader,
output: spv_shader,
+ depend_files: gsk_private_vulkan_include_shaders,
command: [
glslc,
stage_arg,
@@ -61,6 +61,7 @@ foreach shader: gsk_private_vulkan_shaders
compiled_clip_shader = custom_target(clip_spv_shader,
input: shader,
output: clip_spv_shader,
+ depend_files: gsk_private_vulkan_include_shaders,
command: [
glslc,
stage_arg,
@@ -71,6 +72,7 @@ foreach shader: gsk_private_vulkan_shaders
compiled_clip_rounded_shader = custom_target(clip_rounded_spv_shader,
input: shader,
output: clip_rounded_spv_shader,
+ depend_files: gsk_private_vulkan_include_shaders,
command: [
glslc,
stage_arg,