summaryrefslogtreecommitdiff
path: root/gsk/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-03-22 00:45:39 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-03 15:10:54 +0100
commitf67a9d58dbaff870e872a5144645253fe4b524b0 (patch)
tree95204ace3f56dd29dd4b0516ed329909519e8887 /gsk/meson.build
parent48e2b773696736449011abb73d4d3065fedfb907 (diff)
downloadgtk+-f67a9d58dbaff870e872a5144645253fe4b524b0.tar.gz
meson: make sure gsk/gdk generated headers exist for libgtk_dep users
Add back dependencies on libgdk_dep and libsk_dep which are declared dependencies. We removed this before because these declarations had link_with: lines that dragged in the static libgdk.a and libgsk.a libs which are linked into libgtk-4.so anyway and thus shouldn't be used when linking internal exes/tools against libgtk-4. Remove the static libs from the declared dependencies and have libgtk link those in explicitly, so that the declared deps now just provide all the built dependencies and include dirs and such for declared libgtk_dep users such as the internal exes/tools, which want all the generated gsk/gdk/gtk headers to exist before attempting to compile anything against the gtk+ headers.
Diffstat (limited to 'gsk/meson.build')
-rw-r--r--gsk/meson.build12
1 files changed, 7 insertions, 5 deletions
diff --git a/gsk/meson.build b/gsk/meson.build
index 3bd0590a2e..0b8743838b 100644
--- a/gsk/meson.build
+++ b/gsk/meson.build
@@ -157,12 +157,14 @@ libgsk = static_library('gsk',
dependencies: gsk_deps,
include_directories: [confinc],
c_args: ['-DGSK_COMPILATION', '-DG_LOG_DOMAIN="Gsk"'],
-)
+ link_with: libgdk,
+ link_args: ['-Bsymbolic'])
+# We don't have link_with: to internal static libs here on purpose, just
+# list the dependencies and generated headers and such, for use in the
+# "public" libgtk_dep used by internal executables.
libgsk_dep = declare_dependency(
depends: gsk_sources,
- link_with: libgsk,
- link_args: ['-Bsymbolic'],
include_directories: [confinc],
- sources: [gskenum_h, gskresources]
-)
+ sources: [gskenum_h, gskresources],
+ dependencies: libgdk_dep)