summaryrefslogtreecommitdiff
path: root/gsk/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2016-12-16 06:10:24 +0100
committerBenjamin Otte <otte@redhat.com>2016-12-20 18:01:11 +0100
commit85559d1fd9bb47484467b92d1d97411567841bfc (patch)
tree632be09bfbb6ceef97c2a3021c90613b3a955a30 /gsk/Makefile.am
parentba7ac637bccb06d356fad7a1c1a23cdec8e5372e (diff)
downloadgtk+-85559d1fd9bb47484467b92d1d97411567841bfc.tar.gz
vulkan: Split out command pool
This way we can pass the command pool around. And that allows us to allocate and submitcustom buffers. And that is necessary to make staging images work.
Diffstat (limited to 'gsk/Makefile.am')
-rw-r--r--gsk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gsk/Makefile.am b/gsk/Makefile.am
index 395997035d..beadbf3996 100644
--- a/gsk/Makefile.am
+++ b/gsk/Makefile.am
@@ -25,6 +25,7 @@ noinst_LTLIBRARIES =
if HAVE_VULKAN
gsk_private_vulan_source_h = \
gskvulkanbufferprivate.h \
+ gskvulkancommandpoolprivate.h \
gskvulkanimageprivate.h \
gskvulkanmemoryprivate.h \
gskvulkanpipelineprivate.h \
@@ -35,6 +36,7 @@ gsk_private_vulan_source_h = \
gskvulkanshaderprivate.h
gsk_private_vulkan_source_c = \
gskvulkanbuffer.c \
+ gskvulkancommandpool.c \
gskvulkanimage.c \
gskvulkanmemory.c \
gskvulkanpipeline.c \