summaryrefslogtreecommitdiff
path: root/gdk/win32/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2015-08-25 17:41:55 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2015-09-15 18:51:33 +0800
commit6423a02c55db8ef5b497ca06188ab77ff6d8009a (patch)
tree3cd5bf3465c4070eed725fde40297b955cd747dd /gdk/win32/Makefile.am
parent908850c087d3a10aba0cc1e1bb2b08d027d6cefc (diff)
downloadgtk+-6423a02c55db8ef5b497ca06188ab77ff6d8009a.tar.gz
MSVC Builds: Massive Rename of Projects
We need to rename the projects so that when these projects are added into an all-in-one solution file that will build the GTK+ 2/3 stack, the names of the projects will not collide with the GTK+-2.x ones, especially as GTK+-2.x and GTK+-3.x are done to co-exist on the same system. This is due to the case that the MSVC projects are directly carried over from the GTK+-2.x ones and was then updated for 3.x. We still need to update the GUIDs of the projects, so that they won't conflict with the GTK+-2.x ones.
Diffstat (limited to 'gdk/win32/Makefile.am')
-rw-r--r--gdk/win32/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/gdk/win32/Makefile.am b/gdk/win32/Makefile.am
index 65308529d8..e5fea777bf 100644
--- a/gdk/win32/Makefile.am
+++ b/gdk/win32/Makefile.am
@@ -85,20 +85,20 @@ libgdkwin32include_HEADERS = \
gdkwin32window.h
# ------------------- MSVC Build Items ----------------
-MSVCPROJS = gdk-win32
+MSVCPROJS = gdk3-win32
-gdk_win32_FILES = $(libgdk_win32_la_SOURCES)
-gdk_win32_EXCLUDES = dummy
-gdk_win32_HEADERS_DIR = $(libgdkwin32includedir)
+gdk3_win32_FILES = $(libgdk_win32_la_SOURCES)
+gdk3_win32_EXCLUDES = dummy
+gdk3_win32_HEADERS_DIR = $(libgdkwin32includedir)
-gdk_win32_HEADERS_INST = $(libgdkwin32include_HEADERS)
+gdk3_win32_HEADERS_INST = $(libgdkwin32include_HEADERS)
-gdk_win32_HEADERS_EXCLUDES = dummy
+gdk3_win32_HEADERS_EXCLUDES = dummy
include $(top_srcdir)/build/Makefile.msvcproj
dist-hook: \
- $(top_builddir)/build/win32/vs9/gdk-win32.vcproj \
- $(top_builddir)/build/win32/vs9/gdk-win32.headers
+ $(top_builddir)/build/win32/vs9/gdk3-win32.vcproj \
+ $(top_builddir)/build/win32/vs9/gdk3-win32.headers
-include $(top_srcdir)/git.mk