summaryrefslogtreecommitdiff
path: root/gdk/win32/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2003-05-06 21:55:41 +0000
committerOwen Taylor <otaylor@src.gnome.org>2003-05-06 21:55:41 +0000
commit629a0e14248812e55e9245bad9e01d9bc6bd2d0a (patch)
tree4805be6ed3f1fab22e7f536861e8e4f896e63b2c /gdk/win32/Makefile.am
parent2e58122c793a66f6241ff4bfe74e8966a043eeb3 (diff)
downloadgtk+-629a0e14248812e55e9245bad9e01d9bc6bd2d0a.tar.gz
Patch from James Henstridge to update to automake-1.7 (#109542)
Tue May 6 16:50:52 2003 Owen Taylor <otaylor@redhat.com> Patch from James Henstridge to update to automake-1.7 (#109542) * autogen.sh: update to call newer tools. * configure.in: various updates, to use M4 macros to put variables that change each release at the top. Use AC_HELP_STRING to format help strings. Use AC_CONFIG_COMMANDS to generate gdkconfig.h. * Makefile.am: require Automake 1.7. Remove gdk-2.0.pc and gtk+-2.0.pc on uninstall. Pass --enable-gtk-doc to configure during distcheck. * docs/reference/*/Makefile.am: simplify to use the gtk-doc.make makefile fragment. * */Makefile.am: don't use STRIP_BEGIN/STRIP_END. Use BUILT_SOURCES where appropriate. Build generated files in builddir rather than srcdir. Fix uninstall and distclean targets to satisfy distcheck. === * gdk/*/Makefile.am: Remove the hacks to get gdkenumtypes.h built first, since we are now using BUILT_SOURCES. * gdk/Makefile.am: Remove an outdated comment about gdk_headers. * demos/gtk-demo/Makefile.am: Fix srcdir != buildd problem with geninclude.pl. * configure.in: Update versions to 2.3.0.
Diffstat (limited to 'gdk/win32/Makefile.am')
-rw-r--r--gdk/win32/Makefile.am28
1 files changed, 8 insertions, 20 deletions
diff --git a/gdk/win32/Makefile.am b/gdk/win32/Makefile.am
index 4001c5b3e9..9e11c20949 100644
--- a/gdk/win32/Makefile.am
+++ b/gdk/win32/Makefile.am
@@ -2,33 +2,30 @@
libgdkincludedir = $(includedir)/gtk-2.0/gdk
-INCLUDES = @STRIP_BEGIN@ \
+INCLUDES = \
-DG_LOG_DOMAIN=\"Gdk\" \
-DINSIDE_GDK_WIN32 \
-I$(top_srcdir) \
-I$(top_srcdir)/gdk \
-I$(top_builddir)/gdk \
- @GTK_DEBUG_FLAGS@ \
- @GDK_DEP_CFLAGS@ \
- @GDK_WIN32_EXTRA_CFLAGS@\
- -DGDK_COMPILATION \
-@STRIP_END@
+ $(GTK_DEBUG_FLAGS) \
+ $(GDK_DEP_CFLAGS) \
+ $(GDK_WIN32_EXTRA_CFLAGS)\
+ -DGDK_COMPILATION
-LDADDS = @STRIP_BEGIN@ \
- @GDK_DEP_LIBS@ \
-@STRIP_END@
+LDADDS = $(GDK_DEP_LIBS)
if HAVE_WINTAB
libwntab32x_a = .libs/libwntab32x.a
-.libs/libwntab32x.a: @WINTAB_LIB@
+.libs/libwntab32x.a: $(WINTAB_LIB)
cp $< $@
endif
if HAVE_IE55
libie55uuid_a = .libs/libie55uuid.a
-.libs/libie55uuid.a: @IE55_UUID_LIB@
+.libs/libie55uuid.a: $(IE55_UUID_LIB)
cp $< $@
endif
@@ -81,12 +78,3 @@ libgdkinclude_HEADERS = \
gdkwin32.h
libgdk_win32_la_LIBADD = rc/gdk-win32res.lo
-
-###########################################
-# Hack to get gdkenumtypes.h built first
-###########################################
-
-$(libgdk_win32_la_OBJECTS): $(top_srcdir)/gdk/gdkenumtypes.h
-
-$(top_srcdir)/gdk/gdkenumtypes.h:
- @cd $(top_builddir)/gdk && make $(AM_MAKEFLAGS) gdkenumtypes.h