summaryrefslogtreecommitdiff
path: root/gdk/win32/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2014-12-17 12:32:04 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2014-12-17 16:07:02 +0800
commit536fa88cd8a9b0ee99f089da23e455b450622c48 (patch)
treebfa3bb9b08385481d86b8448e51af2b57c867b2f /gdk/win32/Makefile.am
parent9fd9f61b00f1dd7f61beb19cccea5767887a6a4b (diff)
downloadgtk+-536fa88cd8a9b0ee99f089da23e455b450622c48.tar.gz
Add OpenGL Support for the GDK Windows Backend
This adds support for OpenGL to the GDK Windows backend using the WGL API calls, which enables programs that uses the GTK+ GLArea widgets to work on Windows as well. This also adds a simple utility function to query for the version of OpenGL that is supported by the Windows system, like the one provided by the X11 backend. Many thanks to Alex (and Emmanuele, who started the OpenGL integration in GTK+) who offered advice and help along the way, as well as the X11 and Wayland backend for this work to refer to and to model upon. https://bugzilla.gnome.org/show_bug.cgi?id=740795
Diffstat (limited to 'gdk/win32/Makefile.am')
-rw-r--r--gdk/win32/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/gdk/win32/Makefile.am b/gdk/win32/Makefile.am
index 640a215b3e..9366867780 100644
--- a/gdk/win32/Makefile.am
+++ b/gdk/win32/Makefile.am
@@ -37,10 +37,13 @@ libgdk_win32_la_SOURCES = \
gdkdevice-wintab.c \
gdkdevice-wintab.h \
gdkdisplay-win32.c \
+ gdkdisplay-win32.h \
gdkdisplaymanager-win32.c \
gdkdnd-win32.c \
gdkevents-win32.c \
gdkgeometry-win32.c \
+ gdkglcontext-win32.c \
+ gdkglcontext-win32.h \
gdkglobals-win32.c \
gdkinput.c \
gdkkeys-win32.c \
@@ -55,6 +58,7 @@ libgdk_win32_la_SOURCES = \
gdkwin32display.h \
gdkwin32displaymanager.h \
gdkwin32dnd.h \
+ gdkwin32glcontext.h \
gdkwin32.h \
gdkwin32id.c \
gdkwin32keys.h \
@@ -74,6 +78,7 @@ libgdkwin32include_HEADERS = \
gdkwin32display.h \
gdkwin32displaymanager.h\
gdkwin32dnd.h \
+ gdkwin32glcontext.h \
gdkwin32keys.h \
gdkwin32misc.h \
gdkwin32screen.h \