summaryrefslogtreecommitdiff
path: root/gdk/wayland/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2019-11-27 13:33:43 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2019-11-27 13:33:43 +0000
commitdef700739d4f1884be25c63f9df32c583fe4418a (patch)
treeb153cea8052a45d1985e5d9105107dea56d37844 /gdk/wayland/meson.build
parent9f69c7f3e8809af6e97825ae5dd2191c6d4008fc (diff)
downloadgtk+-def700739d4f1884be25c63f9df32c583fe4418a.tar.gz
Use a single compilation symbol
We use a compilation symbol in our build to allow the inclusion of specific headers while building GTK, to avoid the need to include only the global header. Each namespace has its own compilation symbol because we used to have different libraries, and strict symbol visibility between libraries; now that we have a single library, and we can use private symbols across namespaces while building GTK, we should have a single compilation symbol, and simplify the build rules.
Diffstat (limited to 'gdk/wayland/meson.build')
-rw-r--r--gdk/wayland/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/gdk/wayland/meson.build b/gdk/wayland/meson.build
index f40fe3b415..fe094bb7e4 100644
--- a/gdk/wayland/meson.build
+++ b/gdk/wayland/meson.build
@@ -101,7 +101,7 @@ libgdk_wayland = static_library('gdk-wayland',
gdk_wayland_sources, gdk_wayland_gen_headers, gdkconfig, gdkenum_h,
include_directories: [ confinc, gdkinc, ],
c_args: [
- '-DGDK_COMPILATION',
+ '-DGTK_COMPILATION',
'-DG_LOG_DOMAIN="Gdk"',
] + common_cflags,
link_args: common_ldflags,