summaryrefslogtreecommitdiff
path: root/gdk/wayland/meson.build
diff options
context:
space:
mode:
authorOlivier Fourdan <ofourdan@redhat.com>2019-04-15 16:42:45 +0200
committerOlivier Fourdan <ofourdan@redhat.com>2019-04-16 16:14:43 +0200
commit1f58e0ed6b5eaf6140bebdfb3560ba935ce1ef66 (patch)
tree9970cad4e236e797f01559071e9f6b50eed5c550 /gdk/wayland/meson.build
parent1ee5c2cac42b35b7c70739ae0e4e67842da44683 (diff)
downloadgtk+-1f58e0ed6b5eaf6140bebdfb3560ba935ce1ef66.tar.gz
wayland: Add support for xdg-output
Previously, the GDK backend for Wayland would deduce the logical size of the monitors from the wl_output size and scale. With the addition of fractional scaling which advertises a larger scale value and then scale down the client surface, the computed logical size of the monitors in GDK would be wrong and confuse applications which insist on using the monitor size and position (like Firefox). The xdg-output protocol aims at describing outputs in a way which is more in line with the concept of an output on desktop oriented systems by presenting the outputs using their logical size and position appropriately transformed. Add support for the optional xdg-output protocol so that the size and position of the monitors as reported by GDK is correct even when using fractional scaling. Fixes: https://gitlab.gnome.org/GNOME/gtk/issues/1828
Diffstat (limited to 'gdk/wayland/meson.build')
-rw-r--r--gdk/wayland/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/gdk/wayland/meson.build b/gdk/wayland/meson.build
index 0d0cf80851..40f08bdd88 100644
--- a/gdk/wayland/meson.build
+++ b/gdk/wayland/meson.build
@@ -58,6 +58,7 @@ proto_sources = [
['tablet', 'unstable', 'v2', ],
['keyboard-shortcuts-inhibit', 'unstable', 'v1', ],
['server-decoration', 'private' ],
+ ['xdg-output', 'unstable', 'v1', ],
]
gdk_wayland_gen_headers = []